A error on running systemctl --failed

when i run ‘sudo systemctl --failed’ :

Please, next time share the output error as text, not screenshots!

You can mask the service:
sudo systemctl mask systemd-backlight@leds\:dell\:\:kbd_backlight.service
or maybe you need to use this kernel boot parameter:
acpi_osi='!Windows 2012'

I dont know where to include `acpi_osi=’!Windows 2012’

plese help me how to do it.

Is a kernel boot parameter that you add inside /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT line … right after quiet

You have to run from terminal:
sudo update-grub
after you modify it

More about ACPI kernel parameters here:

I have tried but no progress sir :

I have edited /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT=“acpi_osi=‘Windows 2015’ acpi_rev_override=2 quiet apparmor=1 security=apparmor udev.log_priority=3 bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash nvme_core.default_ps_max_latency_us=5500”

and with acpi_rev_override= # (#1 to 5)

That is why i mentioned to mask the service … i don’t think you will get the keyboard light working anyway … What dell laptop model you have, maybe share?
inxi -Fazy

inxi -Fazy :

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=2ec2d427-7779-48cc-8f87-e89b124d5f4a ro "acpi_osi=Windows 2015" 
  quiet apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.13.0 
  date: 08/13/2020 
  ID-1: BAT0 charge: 14.7 Wh condition: 14.7/41.4 Wh (36%) volts: 16.8/14.8 
  model: SMP DELL VN3N047 type: Li-ion serial: <filter> status: Full 
  Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Amber/Kaby Lake note: check family: 6 model-id: 8E (142) stepping: 9 
  microcode: DE L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 21607 
  Speed: 800 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 
  520 Mobile] 
  vendor: Dell driver: radeon v: kernel alternate: amdgpu bus ID: 01:00.0 
  chip ID: 1002:6660 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:3 chip ID: 0bda:5769 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: ati,intel,radeon unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.1 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
  bus ID: 02:00.0 chip ID: 8086:3165 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8136 
  IF: enp3s0 state: down mac: <filter> 
  Local Storage: total: 931.51 GiB used: 255.36 GiB (27.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: SDM3 
  ID-1: / raw size: 130 GiB size: 126.96 GiB (97.66%) used: 10 GiB (7.9%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2 
  ID-3: /home raw size: 801.01 GiB size: 787.44 GiB (98.31%) 
  used: 245.37 GiB (31.2%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 49.0 C mobo: 47.0 C gpu: radeon temp: 45.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 204 Uptime: 4m wakeups: 1 Memory: 7.64 GiB used: 2.34 GiB (30.6%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1270 lib: 380 
  flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.01

Right, so, by default that model has no keyboard backlight unless you custom update it. Only thing left is for you to

thank you very much sir

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.