Zsh shell in the wrong position inside the terminal

Hi everyone,
yesterday i updated Manjaro and done all my work with my pc without touching any config files nor installing anything new.
Today when I booted my pc and opened the terminal the shell was like in the pic

Usually the shell prompt is at the top.
How do I put it back at the top?

check the .zshrc (config) file in your home user directory. It might be corrupted. You can try to modify it or back it up, just in case, and then delete or rename it. Then launch terminal and you will be prompted to recreate etc… then configure to your liking.

I’ve tried doing this.
The shell prompt goes back to default but it is in the same posizion as in the pic

I also get this situation in the vanilla i3 Manjaro version.

Steps to Reproduce (I did it on both VMware and my local machine, performed on 2023-01-27):

  • Install Manjaro i3 (if you are using vm)
  • pamac update
  • Accept everything you prompted by pamac update
  • Reboot
  • Create a new window (make sure the window is maximized)
  • The shell will be displaced at a wrong position like zen did in his first post

Link (output image [from the vm]):
https://i.imgur.com/yL7sr11.jpg

Hello @zen @AbitraryYu :wink:

Looks like urxvt has problems here…

Normally I use alacritty. That’s why I don’t see a problem here.

3 Likes

Thanks for your fast reply @megavolt ! I guess I may try alacritty to see if I could solve this strange offset from urxvt

So urxvt and zsh is having trouble with the latest updates.

Since the manjaro i3 vanilla version is using urxvt, I guess it is prudent to tell anyone who are going to install manjaro i3 (by the time of speaking: 27-1-2023) not to do pamac update or sudo pacman -Syu just yet.

Hopefully someone will fix this.

2 Likes

i have the same problem.

Interesting; I hadn’t noticed this as I only have Kitty and Xterm installed and do not see this behaviour using those. Installing Urxvt I see the prompt appear around half way down like @megavolt.

I am commenting to let you know that I don’t think this is shell specific, I see this with Bash and Dash (so nothing to do with Zsh); it also is not Arch (and derivative) distribution specific, as I also see this on Void. I unfortunately can’t help to say which package update has caused this, as I had not noticed when it appeared for me due to my terminal emulator choice. Rather than hold back updates @AbitraryYu it might be a better idea to switch terminal emulator until the cause is identified.

I agree with @summrum advice if users are not keen to stick with urxvt. I just tried alacritty and it doesn’t have the strange offset, and I think I would stick to alacritty for quite some moment.

A side note for those users who had already upgraded using pamac update or sudo pacman -Syu or equivalent, and still wish to stick with urxvt:

You might find it very difficult to rollback to the version without the strange offset of urxvt. I tried to downgrade the i3 version from i3-wm to i3-gaps before, and perhaps play around with some other dotfiles files like .bashrc, resetting i3 windows Ctrl+shift+r, all of them doesn’t fix the offset of urxvt.

If anyone could find a cure for urxvt users, it would be very beneficial to the community.

It looks like the option for now is to downgrade Urxvt (rxvt-unicode package) if that’s the terminal emulator you want to use; see this Alpine Gitlab report. Also appears that a bug has been filed upstream.