ZSH p10k prompt — special characters don't display (and Neovide bug?)

Dear Manjaro Community,

I have decided to gather some courage and transition to Manjaro Linux lately (KDE Plasma). I have some problems, however, which I couldn’t resolve by myself:

  1. Some special characters in my p10k prompt don’t seem to display.
    This problem exists both in my VSCodium and in Yakuake/Konsole terminal.

I have tried installing and using different fonts (Noto Mono, Roboto Mono, Hack etc.), currently I’m using Source Code Pro for Powerline. None of these helped the situation.

Disclaimer: I have installed fcitx for Asian languages. Not sure if it changes anything.

My ZSH configuration files: Zsh config – Google Drive

  1. The Neovide seems to not display anything when launched at first, requires scrolling through to show any characters at all. I have tried changing my init.vim / init.lua (installed Astro Vim), this didn’t change anything. Not sure if it’s connected to the ZSH bug:

I will be very thankful for any help.
Best regards,

I’ve tried Nerd Fonts, including Meslo. Unfortunately, none of them work, it still shows the same weird characters. :frowning:

I have tried re-configuring p10k with Meslo. Apparently, I wasn’t using any special characters in the prompt. The ones I’ve added work perfectly well.

Edit: I’ve searched some more and these “!4 ?1” are actually a default behavior of the p10k, which doesn’t use any special characters to indicate these values in Git repositories. So there was actually no bug in the first place.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.