Zsh default powerline font glyph display issue

I’ve recently switched to Manjaro, and chose to install the KDE version. One of the first things I did was change the default shell to zsh and was pleasantly surprised with the default prompt. There seems to be some flakiness to it, though.

The glyph for “home” and “locked” directories was displaying correctly at first, and in some terminals (putty after I installed patched font - DejaVuSansMono NF), but now it doesn’t seem to display correctly in alacritty and yakuake (DejaVu Sans Mono). The Manjaro log and timer glyphs display correctly.

Any thoughts or suggestions? Screenshots attached of “correct” and glitched. Edit - sorry, can’t seem to upload screenshots.

Try using the recommended font ttf-meslo-nerd-font-powerlevel10k and setting it manually:

Alacritty : Create or open ~/.config/alacritty/alacritty.yml and add the following section to it:

font: normal: family: “MesloLGS NF”

Not sure about Yakuake, check it’s settings.

Boom! Perfect! Thankyou!

Not bad, but Ligconsolata font looks nicer IMO :wink: take a look.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.