Zoom not installing (libc.so.6: version `GLIBC_2.32' not found)

Hi,
I’m writing “sudo pacman -U zoom…tar.xz” on terminal.
And terminal say:
sudo: /usr/lib/libc.so.6: version `GLIBC_2.32’ not found (required by /usr/lib/sudo/libsudo_util.so.0)

I think this glibc of last version but i dont know upgrade. Thank you. :slight_smile:

I fear the way you try to install something in Manjaro is not the proper procedure. :woozy_face:
https://wiki.manjaro.org/index.php/Using_Manjaro_for_Beginners
https://wiki.manjaro.org/index.php/Pamac
https://wiki.manjaro.org/index.php/Pacman_Overview
https://wiki.manjaro.org/index.php/Arch_User_Repository

zoom can be found in AUR. To install it you need to use pamac command or an AUR helper such as yay. So install it eiher by

pamac upgrade -a
pamac build zoom

or

yay -Syu zoom

(P.S. If pamac or yay are not installed on your system you have to install them upfront.)

2 Likes

Thank you. But i trying install pamac with this code
sudo pacman -Syyu base-devel git
but terminal say
sudo: /usr/lib/libc.so.6: version `GLIBC_2.32' not found (required by /usr/lib/sudo/libsudo_util.so.0) again. i dont understand. :frowning:

(i wanna install zoom for online subject on tomorrow. and i should very very fast. this is my first linux adventure :smiley: thx)

First clean your pacman cache and update:

sudo pacman -Sc
sudo pacman-mirrors -f && sudo pacman -Syyu

and reboot.

If update was successful then try to install pamac again by:

sudo pacman -S pamac

If it’s working install zoom by:

pamac build zoom

If it’s still not working then start from the scratch with some system info, please post

inxi -Fazy
sudo pacman -Sc
sudo pacman-mirrors -f && sudo pacman -Syyu    
inxi -Fazy  

Not working.
What do you think about? I always keep getting this:

sudo: /usr/lib/libc.so.6: version `GLIBC_2.32' not found    

I think trouble this. I dont know. I dont using lastest Manjaro version now. I have already .iso file. And i use it. My laptop specs: i5-2430m, 4GB RAM, 500GB HDD, HP Pavilion G6.

inxi -Fazy
Error 10: Unsupported value: 0 for option: y
Check -h for correct parameters.

What Manjaro ISO did you use for installation, exactly and when did you update, last time?

I use manjaro-xfce-20.0.1 version and i didnt update yet. I was install manjaro on laptop today.

Manjaro is a rolling release distro and you should update on a regular intervall after reading #announcements. Otherwise, you risks issues as sometimes the update procedure is changed and this forms issues for older systems which have not been prepared for the changes. Maybe some more experienced forum members have an idea how to solve your specific issue. If your install is fresh, I would rather reinstall if you are in a hurry and use the newest 20.1.1 xfce ISO you can get here:

https://manjaro.org/download/

1 Like

I install lastest version and Solved! Thank you.

1 Like