Zoom (App) Screen Share Flickering

I am screen sharing on Zoom but the viewers say it is flickering. When I disable “Blur” on “desktop effects” flickering stops. Flickering effects windows only not the whole screen. Note that I don’t see any flickering. Tried with multiple kernels. However, disabling Blur seems like the only option. How can I fix this?

  Kernel: 4.19.160-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 
  root=UUID= [id] rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.20.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux

I use Mageia 7.1, KDE Plasma and I also have the problem of “flickering” except mine is really bad. My clients cannot read the shared screen-- about 1/4 of it gets replaced by my desktop behind the shared window. I also have tried a variety of kernels, and a variety of zoom versions. This all happened sudeenly about a month ago, perhaps after an update.
I do not have “blur” actiated on the desktop (whatever that is).
Again I have no problem on my end-- no flickering, not replacement. Everything seems fine.
But the clients are driven completely batty and what they see is unreadable because of the “flickering”. No solution, just another tortured soul.

By “blur” I meant: System Settings → Workspace → Workspace Behavior → Desktop Effects → Appearance → Blur

Also, only sharing the app window instead of whole desktop solves the issue at my end. However, I MUST share the desktop. :frowning:

I had the same problem on KDE Manjaro using the Plasma DE. It seems the problem is due to the compositor settings. I fixed it by doing this: Go to “Settings” → “Hardware” → “Display and Monitor” → “Compositor” → Change “Tearing prevention (vsync)” to “never”, Change “Keep window thumbnails” to “never”, Change “Scale method” to “smooth”.

I didn’t troubleshoot exactly which one of these three options made a difference for me (my guess is the “vsync” option), but making the above the three changes fixed the problem for me. Now when I share screen on Zoom, it no longer flickers to my desktop on other users’ screen.

1 Like

I had the same problem on KDE Manjaro with Plasma DE. I had success sharing without flickering after only changing “Keep window thumbnails” to “never”