ZFS won't install because of format error (Manjaro on ZFS)

Hello everyone!
So first of all: I hope I post this question in the right section, because I am not entirely sure about that.
So after installing arch linux on zfs, I came across an error that didn’t let me start any desktop engine. My plan now is to install manjaro on zfs instead, since it already has preconfigured and working desktop engine. Since calamares does not support zfs, manjaro architect kinda lacked the zfs feature as I tried to install and is basically discontinued and there is no manjaro iso out there with built in zfs support, I wanted to install manjaro on an ext4 partition of my computer (which is currently booting with systemd-boot btw, since grub didn’t want to work with encrypted zfs pool), boot into it, add zfs packages, rebuild initramfs, move kernel images into efi directory and create boot entry, test boot, then move the system into the zfs system, adjust the root boot option in systemd-boot entry config to point to the zfs root, be done and be able to boot into manjaro on zfs.

Now sadly I wasn’t able to come that far…
I installed manjaro and made a boot entry for it aswell. It even boots and everything, but it is not able to activate the zfs module in the kernel. Not at boot and not with “modprobe zfs”.
The error is modprobe: ERROR: could not insert 'zfs': Exec format error
I installed zfs-utils and linux515-zfs (“uname -r” returned “5.15.32-1-MANJARO”, so i assumed linux515 was right).

What am I doing wrong? Is it simply impossible to install manjaro on zfs? Do I need to change my kernel, to a normal linux kernel and not manjaro? Any better ideas than the way I tried to install manjaro on zfs?

Thanks in advance!

Not to hijack, but is there a strong reason you must have Manjaro installed to a ZFS root?

Is there something with ZFS that you need (for the system itself, not in regards to /home/ or any other custom path), that cannot be met with BTRFS?

Caveat: Even if you are successful, keep in mind there’s a higher degree of risk with updates, and especially with kernel upgrades and/or kernel changes.

It is difficult to install zfs on Manjaro. But there is unofficial zfs on Endeavous OS:

You can install zfs via calamares after editing calamares setup. (You can try to test it in VM)

1 Like

I have a few partitions that are from a previous windows installation. To save me on time with partitioning (since I am planing to transfer everything to a linux file system like ext4, zfs, xfs, whatever) I figured that a logical volume manager could be helpful. Since I want full system encryption (except for an efi partition) due to me being paranoid, I first tried to install manjaro on luks encrypted lvm. This failed and after this I got into zfs. Seeing that zfs had some advantages like compresssion, built in encryption, being a logical volume manager and a filesystem and so on.
Since I wasn’t able to install manjaro on encrypted luks, nor zfs I tried it with arch. Which, as stated in the beginning, worked but didn’t give me any graphical desktop.
So here I am, trying to install manjaro with zfs again.

But maybe I will go back to arch again and try to fix that desktop problem.
Sadly nobody on the arch forum seemed to be able to help me, let alone know where the error exactly was.

But if I tried to edit the calamares skript, wouldn’t my host system need the zfs package, to be able to write onto the datasets? I mean it seems like I can’t even get the zfs support on my host system to work, because of the error mentioned at the beginning.

This is a bombastic approach to achieving your desired outcome.

You can get full system encryption with LUKS, where the filesystem (and LVM if needed) lay atop this encrypted layer.

Why not use the route of:



  • LUKS + LVM + EXT4 / XFS

I’ve tried a ZFS root Manjaro setup before, and while I absolutely love ZFS, I found it not worth the risk.

1 Like

I did it this way. Sad. I was really excited about zfs, but I guess I will just hope for better implementation in the future. Closing thread and thanks for the help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.