Zenbook UP6502ZD_Q539ZD Audio issue


I’m dual booting Windows 11 with Manjaro KDE, and I have no sound. Headphones work while the speakers don’t. I have tried multiple solutions and had no luck whatsoever.

This is a Zenbook UP6502ZD_Q539ZD.
Card: sof-hda-dsp
Chip: Realtek ALC294

Below is some system information:

$ inxi -Fxz                                                                                      ✔ 
  Kernel: 6.2.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: KDE Plasma v: 5.26.5 Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: ASUSTeK product: Zenbook UP6502ZD_Q539ZD v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UP6502ZD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: UP6502ZD.307 date: 09/08/2022
  ID-1: BAT0 charge: 88.7 Wh (100.0%) condition: 88.7/96.0 Wh (92.4%)
    volts: 13.2 min: 11.7 model: ASUSTeK ASUS Battery status: full
  Device-1: hid-0018:04F3:2F09.0002-battery model: ELAN9008:00 04F3:2F09
    charge: N/A status: N/A
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP arch: Alder Lake rev: 3 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 2591 high: 2700 min/max: 400/4600:4700:3500 cores:
    1: 2700 2: 2700 3: 2700 4: 2700 5: 2700 6: 2700 7: 524 8: 2700 9: 2700
    10: 2700 11: 2700 12: 2700 13: 2700 14: 2700 15: 2700 16: 2700 17: 2700
    18: 2700 19: 2700 20: 2700 bogomips: 107560
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.2 bus-ID: 0000:00:02.0
  Device-2: Intel DG2 [Arc A370M] vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-12.7 bus-ID: 0000:04:00.0
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 2-9:3
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 2880x1620~120Hz
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3
  Sound API: ALSA v: k6.2.6-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 2-10:4
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0
  Local Storage: total: 953.87 GiB used: 10.86 GiB (1.1%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM001TD3JX013N
    size: 953.87 GiB temp: 37.9 C
  ID-1: / size: 294.23 GiB used: 10.79 GiB (3.7%) fs: ext4 dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 256 MiB used: 73.2 MiB (28.6%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  Src: /sys System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 3000
  Processes: 366 Uptime: 26m Memory: 15.32 GiB used: 4.48 GiB (29.2%)
  Init: systemd Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1118 Shell: Zsh
  v: 5.9 inxi: 3.3.25

I would like to also mention that it shows that sound is coming out while it actually doesn’t.

In addition to that, I want to mention that I have already tried countless solutions that I have found on forums and other online sources and nothing has worked for that. Furthermore, I have attempted to solve this issue on multiple linux distros, and the issues persists across all of them.

I don’t know what to do anymore and I would really really appreciate any help.

Thank you in advance.

I have the same laptop model and am experience the same issues. Tried multiple linux distros, updating kernals, etc… The sound shows it is playing, but no sound comes from the speakers.

I had the reverse problem on Asus Zenbook UX370UAR with Realtek ALC295: the speakers worked, the wired headphones - not.

First, you should have only one sound server running - either pulseaudio or pipewire. You now have both of them running. I also had them both running so I installed the meta package manjaro-pipewire and it removed the conflicting pulseaudio (I choose pipewire just because it sounds cooler and more modern).

Then put the following line into your /etc/modprobe.d/alsa-base.conf:

options sof-audio-pci-intel-tgl index=0 model=asus-zenbook

and reboot. If it doesn’t help, try with another model from HD-Audio Codec-Specific Models — The Linux Kernel documentation, there is also asus-zenbook-ux31a

OP could not have 2 sound servers running, inxi reporting PipeWire running was a known false positive

How to prevent/disable suspend on idle (PipeWire)? - #2 by Yochanan

Just because PipeWire is installed and the service is waiting does not mean both PulseAudio and PipeWire are actually running at the same time.

You can verify which sound server is running the following command:

pactl info

inxi developer comments from later in that discussion show changes implemented to show audio server information with improved accuracy

But reconfiguring software audio servers is not effective if there is an underlying issue in ALSA

Modprobe model option asus-zenbook was reported to work partially for ROG Strix G712LV with ALC294 codec
Audio doesn’t work in internal speaker but it works on Headphones
audio playback from speakers worked, but could only be set to 0 or 100%

Another user posted how to reconfigure PulseAudio alsa-mixer paths for ALC294 on ROG Strix G512LU to get speaker level control working
Speaker/headphone device switching issues ROG Strix G15 - #11 by gameslayer9999