Youtube keeps buffering, output devices do not work

The Initial Problem

My bluetooth earphone did not connect with manjaro suddenly. Removing device and then reconnecting worked. Now, I looked up the possible solutions, and since reinstalling bluez did not help, I took to some other solution which I cannot recall.

The supposed Resolution


Next time I come, the bluetooth does connect seamlessly, but now youtube gets stuck at “If playback doesn’t begin shortly, try restarting your device.”

Output Devices

I tried playing a downloaded video(.mkv file) and it plays, but no audio output comes. On going to settings and testing Output Audio, i received no output.

Tried to resolve

pipewire-media-session conflicting with wireplumber seemed to be an issue, but none get installed/removed because of a series of conflicting dependencies. What I mean is, say wireplumber cannot be uninstalled because pipewire-media-session requires it. Uninstalling pipewire-media-session works, but then wireplumber is required by pipewire-alsa, or something similar, and this continues in a series which eventually ends in a loop. Not sure what needs to be done.

PS : completely new to Manjaro(2nd distro after few months of Ubuntu), not very sure what dependecies might be relevant regarding my problem, do tell me, and I will post them promptly, thanks :slight_smile:

This would make more sense if you included the actual attempt and output.

pipewire-media-session is deprecated.

I suppose a guess would be to tell you to sync/upgrade while installing the meta package;

sudo pacman -Syu manjaro-pipewire

pipewire-alsa Depends On pipewire, pipewire-audio and pipewire-session-manager

pipewire-session-manager Depends On wireplumber

wireplumber Conflicts with pipewire-media-session
and pipewire-media-session Conflicts with wireplumber

PipeWire - Session manager - ArchWiki
PipeWire implements no connection logic internally. The burden of watching for new streams and connect them to the appropriate output device or application is left to an external component known as a session manager.

Currently, the only recommended session manager is WirePlumber

The following session manager is deprecated in favor of WirePlumber: PipeWire Media Session

Are these really true at the same time?

…just checked. And no, this is not true.

Well - the first part is not. The second part is.

And anyways … its still true that pipewire-media-session is deprecated.

If not now then some time soon folks will need to move to wireplumber as their session manager.

(and they should now if they can)

$ pamac info pipewire-session-manager
Name                  : pipewire-session-manager
Version               : 1:1.0.4-4
Description           : Session manager for PipeWire (default provider)

Depends On            : wireplumber
$ pamac info wireplumber
Name                  : wireplumber
Version               : 0.5.1-2
Description           : Session / policy manager implementation for PipeWire
Provides              : pipewire-session-manager

Conflicts With        : pipewire-media-session
$ pamac info pipewire-media-session
Name                  : pipewire-media-session
Version               : 1:0.4.2-2
Description           : Legacy session manager for PipeWire (deprecated)

Provides              : pipewire-session-manager

Conflicts With        : wireplumber

PipeWire / media-session · GitLab

PipeWire Media Session is an example session manager for PipeWire.
Note that we recommend the use of WirePlumber instead.

1 Like


!= pipewire-media-session

I guess that pipewire-session-manager is just really a link to whatever is default - wireplumber.
(that package itself provides no files)

In that giant split package here:

Its just

package_pipewire-session-manager() {
  pkgdesc="Session manager for PipeWire (default provider)"

(so also fine its missing on my system :innocent:)

1 Like

Current version of manjaro-pipewire does not ask user to choose a session-manager like older versions, just installs wireplumber

AFAICT pipewire-session-manager is just a metapackage to ensure wireplumber and libwireplumber are installed

OP and other users could use this to replace pipewire-media-session

$ pamac install pipewire-session-manager

To install (3):
  libwireplumber            0.5.1-2    (Required By: pipewire-session-manager)  extra  269.7 kB
  wireplumber               0.5.1-2    (Required By: pipewire-session-manager)  extra  235.2 kB
  pipewire-session-manager  1:1.0.4-4                                           extra  3.7 kB
1 Like

That guess was definitely correct.
The package I had installed in a hope to fix my bluetooth connectivity issues was ‘pulse audio’ , which conflicted with pipewire. Trying to upgrade pipewire gave me the conflicting packages, and asked if i wanted to remove pulseaudio, and I did, so now my sound output devices, and youtube work.

It’s not even that. It’s just a bunch of words. :stuck_out_tongue:

To explain: If multiple packages provide the same functionality that other packages might depend on, then you can just specify that functionality in provides=() array and name it whatever and make other packages depend on said functionality.

Eh, I’m still sleeping it seems.

Given your previous statements … why would one need to install the session-manager-nothing-package at all, or explicitly?

Would not

Do that fine because

$ pacman -Qi manjaro-pipewire
Name            : manjaro-pipewire
Version         : 20231009-1
Description     : Manjaro meta package for complete PipeWire support.
Architecture    : any
URL             :
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : gst-plugin-pipewire  pipewire  pipewire-alsa  pipewire-pulse

It makes more sense to get the broader meta, at least in the majority of cases. I would think.

Manjaro also has manjaro-pulse metapackage to replace PipeWire packages with PulseAudio packages. PulseAudio packages could be installed without the metapackage

pamac install pulseaudio pulseaudio-alsa pulseaudio-bluetooth

If I were to install the broader meta, pamac would install the other meta too

$ pamac install manjaro-pipewire

To install (10):
  libwireplumber            0.5.1-2      (Required By: manjaro-pipewire)     extra  269.7 kB
  wireplumber               0.5.1-2      (Required By: manjaro-pipewire)     extra  235.2 kB
  pipewire-session-manager  1:1.0.4-4    (Required By: manjaro-pipewire)     extra  3.7 kB
  gst-plugin-pipewire       1:1.0.4-4    (Required By: manjaro-pipewire)     extra  52.0 kB
  alsa-card-profiles        1:1.0.4-4    (Required By: manjaro-pipewire)     extra  27.6 kB
  libmysofa                 1.3.2-1      (Required By: manjaro-pipewire)     extra  1.2 MB
  pipewire-audio            1:1.0.4-4    (Required By: manjaro-pipewire)     extra  1.2 MB
  pipewire-alsa             1:1.0.4-4    (Required By: manjaro-pipewire)     extra  5.0 kB
  pipewire-pulse            1:1.0.4-4    (Required By: manjaro-pipewire)     extra  192.0 kB
  manjaro-pipewire          20231009-1                                       extra  24.1 kB
To remove (3):
  pulseaudio-alsa           1:  (Conflicts With: pipewire-alsa)     extra
  pulseaudio-jack           17.0-3       (Conflicts With: manjaro-pipewire)  extra
  pulseaudio                17.0-3       (Conflicts With: pipewire-pulse)    extra
1 Like

Yeah, thats my point.

(and so we can go all the way back and mark the first response as the solution :wink:)

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.