Yousician installed in Wine has stuttering graphic

I have installed Yousician in Wine 32 but when I launch I get the message “Yousician server cannot be reached. Check your internet connection and try again”. The interesting thing is that it works in Mageia. Is there some extra packages that needs to be installed under Manjaro?

When I launch in konsole:

env WINEPREFIX="/home/hans/.wine" wine C:\\users\\hans\\AppData\\Roaming\\Yousician\ Launcher\\Yousician\ Launcher.exe 

I get:

System info
0024:fixme:nls:get_dummy_preferred_ui_language (0x8 0032FA9C 00000000 0032FAA0) returning a dummy value (current locale)
0024:fixme:nls:get_dummy_preferred_ui_language (0x8 0032FA9C 00D218A8 0032FAA0) returning a dummy value (current locale)
0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
    Launcher:     Yousician-launcher
    Version:      04.10.2021 2.6.45 c7392b4
    Build name:   Windows_2.6.45_c7392b4_2021-10-04_0846
    Compile date: JUCE v6.1.2 4 Oct 2021 8:51
    OS:           Windows 10 64 bit
    Device:       Windows (Desktop)
    CPU model:    Intel(R) Celeron(R) CPU 3867U @ 1.80GHz
    CPU cores:    2C/2T
    Memory size:  19303 MB
    User region:  DK
    User lang:    da
    Display lang: da-DK
0024:fixme:system:EnableNonClientDpiScaling (00010058): stub
0024:fixme:win:RegisterTouchWindow (00010058 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 00010058 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010058 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010058 49 1 00000000
0024:err:ole:com_get_class_object class {4ce576fa-83dc-4f88-951c-9d0782b4e376} not registered
0024:err:ole:create_server class {4ce576fa-83dc-4f88-951c-9d0782b4e376} not registered
0024:err:ole:com_get_class_object no class object {4ce576fa-83dc-4f88-951c-9d0782b4e376} could be created for context 0x6
0024:fixme:system:EnableNonClientDpiScaling (00020058): stub
0024:fixme:win:RegisterTouchWindow (00020058 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 00020058 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00020058 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00020058 49 1 00000000
Using default config
Work0070:fixme:imm:ImeSetActiveContext (0x25e270, 0): stub
0070:fixme:imm:ImmReleaseContext (0000000000010020, 000000000025E270): stub
ing dir: "C:0024:fixme:system:EnableNonClientDpiScaling (00010066): stub
\users\h0024:fixme:win:RegisterTouchWindow (00010066 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 00010066 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010066 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010066 49 1 00000000
ans\AppData\Roaming\Y0024:fixme:system:EnableNonClientDpiScaling (0001006C): stub
ousicia0024:fixme:win:RegisterTouchWindow (0001006C 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 0001006C 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 0001006C 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 0001006C 49 1 00000000
n Launcher"
Checkin0024:fixme:system:EnableNonClientDpiScaling (00010072): stub
g Yousici0024:fixme:win:RegisterTouchWindow (00010072 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 00010072 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010072 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010072 49 1 00000000
an API connection
0104:fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_DISABLE_AUTODIAL; STUB
0104:fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_DATA_RECEIVE_TIMEOUT (10000): STUB
0024:fixme:system:EnableNonClientDpiScaling (00010078): stub
0024:fixme:win:RegisterTouchWindow (00010078 00000000): stub
0024:fixme:msg:ChangeWindowMessageFilterEx 00010078 233 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010078 4a 1 00000000
0024:fixme:msg:ChangeWindowMessageFilterEx 00010078 49 1 00000000
0024:fixme:imm:ImeSetActiveContext (0x6ea140, 1): stub
0024:fixme:imm:ImmReleaseContext (00020058, 006EA140): stub
0104:err:winediag:gnutls_initialize Failed to load libgnutls, secure connections will not be available.
0104:err:secur32:SECUR32_initSchannelSP no schannel support, expect problems
0104:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0162F94C 1 C) semi-stub
0104:fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0162F86C 1 C) semi-stub
ERROR: API call timed out after 0.2 seconds
ERROR: Failed to get API status message
ERROR: Could not reach Yousician API, waiting for network connection
0104:fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_DISABLE_AUTODIAL; STUB
0104:fixme:wininet:InternetSetOptionW Option INTERNET_OPTION_DATA_RECEIVE_TIMEOUT (10000): STUB

Thanks to a former thread I solved the issue by
sudo pacman -S lib32_gnutls

So now Yousician works, but alas … there is no sound. Any suggestions?

Provide Information:

Thank you very much for your help
So here is my system info. Quite a bunch. I hope it can be of some help:

[hans@hans-81hn ~]$ inxi --admin --verbosity=7 --filter --width         
  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=e2afb154-6d14-456f-8d73-1e12ce3dccb1 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81HN v: Lenovo V130-15IKB
    serial: <superuser required> Chassis: type: 10 v: Lenovo V130-15IKB
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN
    serial: <superuser required> UEFI: LENOVO v: 8VCN29WW date: 05/17/2021
  ID-1: BAT0 charge: 29.0 Wh (100.0%) condition: 29.0/30.6 Wh (94.6%)
    volts: 8.5 min: 7.6 model: CPT-COS L17C2PB3 type: Li-poly serial: <filter>
    status: Full cycles: 24
  RAM: total: 11.04 GiB used: 2.46 GiB (22.3%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron 3867U bits: 64 type: MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEA
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
    desc: 1x2 MiB
  Speed (MHz): avg: 798 high: 800 min/max: 400/1800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 797 2: 800 bogomips: 7202
  Flags: 3dnowprefetch abm acpi aes aperfmperf apic arat arch_perfmon art
    bts clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de
    ds_cpl dtes64 dtherm dts epb ept ept_ad erms est flexpriority flush_l1d
    fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep sgx smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:5906 class-ID: 0300
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-5:2 chip-ID: 04ca:7070 class-ID: 0e02
  Display: x11 server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
    diag: 394mm (15.5")
  OpenGL: renderer: Mesa Intel HD Graphics 610 (KBL GT1) v: 4.6 Mesa 21.3.2
    direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Device-2: M-Audio Uno type: USB driver: snd-usb-audio bus-ID: 1-1:7
    chip-ID: 0763:0150 class-ID: 0103
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: no
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
    v: kernel bus-ID: 02:00.0 chip-ID: 8086:3166 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 18.53 GiB (15.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: 0107ADLA temp: 51.9 C scheme: GPT
  Optical-1: /dev/sr0 vendor: PLDS model: DVD-RW DA8AESH rev: XL6M
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 16.6 GiB size: 16.17 GiB (97.42%) used: 12.91 GiB (79.8%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: e2afb154-6d14-456f-8d73-1e12ce3dccb1
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 30.7 MiB (12.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM_DRV uuid: 582D-32D5
  ID-3: /home raw-size: 29.29 GiB size: 28.66 GiB (97.86%)
    used: 5.59 GiB (19.5%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 74b7b6bc-be7a-4771-9700-38c2006a79f0
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A
    uuid: 4befc802-2a53-41da-b155-2255772ec7c6
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 64.28 GiB fs: ntfs
    label: Windows-SSD uuid: 4C082E0F082DF89A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 1000 MiB fs: ntfs
    label: WINRE_DRV uuid: BA4A2F0A4A2EC34D
  ID-4: /dev/nvme0n1p8 maj-min: 259:8 size: 10 MiB fs: <superuser required>
    label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:7 info: M-Audio Uno type: Audio driver: snd-usb-audio
    interfaces: 2 rev: 1.0 speed: 12 Mb/s chip-ID: 0763:0150 class-ID: 0103
  Device-2: 1-5:2 info: Lite-On Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04ca:7070 class-ID: 0e02
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 42.0 C pch: 41.0 C mobo: 38.0 C
  Fan Speeds (RPM): N/A
  Processes: 177 Uptime: 6h 7m wakeups: 54600 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1202
  lib: 354 flatpak: 0 Shell: Bash v: 5.1.12 running-in: xfce4-terminal
  inxi: 3.3.11

Btw: I have solved my problem with sound in Yousician by installing lib32-alsa-utils and lib64-libpulse.
Now my final struggle is that the graphics is kind of stuttering. In Yousician the notes are sliding in horizontally from left to right. And it would be nice if it could be a little more smooth. It is in Windows 10 and in Mageia (sorry for comparing to other OS’es).
So here is my randr-output too:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
eDP-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768      60.00*+
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
HDMI-1 disconnected (normal left inverted right x axis y axis)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.