You need to load kernel first, chroot failing from live usb

Hello, I updated the packages using the command pacman -Syu
mistake: i didnt check the update logs and cleared my terminal

When booting the system again it says:
error: file /boot/vmlinuz-5.10-x86_64 not found.
error: you need to load the kernel first.

What I tried

  1. I tried booting a different kernel it showed file system errors so i tried to fix it using fsck command like usual after that i tried to reboot in the same kernel but there is a error message that says kernel panic not syncing attempted to kill init!

  2. I booted from a live USB and tried running manjaro-chroot -a

grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]
chroot: failed to run command '/bin/bash': Input/output error
 --> umount: [/mnt/home]
 --> umount: [/mnt/boot/efi]
 --> umount: [/mnt]

Kindly let me know if any more information is needed as this is ny first time creating a topic

That’s not chroot failing, that’s chroot informing you that /bin/bash could not be executed. Weird, true, but not chroot itself failing.

But it sounds like a problem with you hard drive. Boot into a live environment and provide the output of:

sudo inxi --admin --verbosity=7 --filter --no-host --width


Thanks for pointing out about chroot

Following is the output:

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2137 quiet systemd.show_status=1
    driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Console: pty pts/2 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DD v: 1.0
    serial: <filter>
  Mobo: ASUSTeK model: FX505DD v: 1.0 serial: <filter>
    UEFI: American Megatrends v: FX505DD.317 date: 03/11/2021
  ID-1: BAT0 charge: 32.3 Wh (100.0%) condition: 32.3/48.2 Wh (66.9%)
    volts: 12.5 min: 11.9 model: FX50442 type: Li-ion serial: N/A status: full
  RAM: total: 5.72 GiB used: 2.12 GiB (37.1%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
    note: est.
  Device-1: DIMM 0 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: spec: 2667 MT/s actual: 2400 MT/s volts: curr: 1.2
    min: 1.2 max: 1.2 width (bits): data: 64 total: 64 manufacturer: Samsung
    part-no: M471A1K43DB1-CTD serial: <filter>
  Device-2: DIMM 0 type: no module installed
  Info: model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx socket: FP5
    bits: 64 type: MT MCP arch: Zen/Zen+ note: check gen: 1 built: 2019
    process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
    microcode: 0x8108102
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1400 min/max: 1400/2100 boost: enabled
    base/boost: 2100/3700 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1400 2: 1400 3: 1400 4: 1400
    5: 1400 6: 1400 7: 1400 8: 1400 bogomips: 33548
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107M [GeForce GTX 1050 3 GB Max-Q] vendor: ASUSTeK
    driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-07)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s ports:
    active: none empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1c91
    class-ID: 0300
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: none bus-ID: 04:00.0 chip-ID: 1002:15d8
    class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x0036 built: 2018
    res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.42
    5.15.60-1-MANJARO) v: 4.6 Mesa 22.1.6 direct render: Yes
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: Unknown lanes: 63 link-max:
    gen: 6 speed: 64 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter
    vendor: AzureWave driver: rtw_8822be v: N/A modules: rtw88_8822be pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:b822 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 13d3:3526 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 939.05 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B sata: 3.3
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0J temp: 39 C
    scheme: GPT
  SMART: yes state: enabled health: PASSED on: 303d 21h cycles: 3125
    Old-Age: g-sense error rate: 2929 Pre-Fail: reallocated sector: 100
    threshold: 50
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Transcend
    model: JetFlash 8GB size: 7.54 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> rev: 8.07 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 260 MiB fs: vfat label: SYSTEM
    uuid: B42D-3BFD
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: N/A label: N/A uuid: N/A
  ID-3: /dev/sda3 maj-min: 8:3 size: 720.41 GiB fs: ntfs label: OS
    uuid: EA1A2FDF1A2FA811
  ID-4: /dev/sda4 maj-min: 8:4 size: 850 MiB fs: ntfs label: RECOVERY
    uuid: 40C898C5C898BB1C
  ID-5: /dev/sda5 maj-min: 8:5 size: 43.95 GiB fs: ext4 label: N/A
    uuid: 5c0fc376-aa28-42b4-b78a-5305b6c0b33e
  ID-6: /dev/sda6 maj-min: 8:6 size: 154.3 GiB fs: ext4 label: N/A
    uuid: 829a5f0c-9640-4d92-af1f-86da725343fb
  ID-7: /dev/sda7 maj-min: 8:7 size: 11.76 GiB fs: swap label: N/A
    uuid: 21e4944b-420b-4c45-b920-57cf6fa26563
  ID-8: /dev/sdb1 maj-min: 8:17 size: 3.32 GiB fs: iso9660
  ID-9: /dev/sdb2 maj-min: 8:18 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: C80E-8B3F
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Transcend Information JetFlash type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA
    chip-ID: 8564:1000 class-ID: 0806 serial: <filter>
  Device-2: 1-4:3 info: IMC Networks Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 13d3:3526 class-ID: e001 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: IMC Networks USB2.0 HD UVC WebCam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 1 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 57.6 C mobo: N/A
  Fan Speeds (RPM): cpu: 3600
  GPU: device: nouveau temp: N/A device: amdgpu temp: 57.0 C
  Processes: 267 Uptime: 3m wakeups: 1 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6 Packages: pacman: 1209
  lib: 318 flatpak: 0 Shell: Zsh (sudo) v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.20

Hmm, the device isn’t mentioned in the chroot output…let’s test it. Run the following:

sudo smartctl --health /dev/sda

And provide that here, please.

smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.15.60-1-MANJARO] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

SMART overall-health self-assessment test result: PASSED

OK, looks good so far. So let’s try the chroot again.

To chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

When in the chroot environment, let me know by replying with the output of the following, run from within the chroot environment:

mhwd-kernel --listinstalled


mhwd-kernel --list

I am live rn from the latest manjaro kde iso

now the chroot output has changed and is very weird:

/usr/share/os-prober/ line 15: /usr/bin/mktemp: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
/usr/share/os-prober/ line 95: /usr/bin/readlink: Input/output error
==> ERROR: No Linux partitions detected!

tried running the command using sudo as well but same output

tried sudo su -

sudo: unable to execute /usr/bin/su: Input/output error

Still looks like some kind of HDD error to me. Let’s start from the beginning:

Restart, completely restart your PC and boot into a live environment. When done, open a terminal and run:

sudo smartctl --test short /dev/sda

…and provide the output here, please.

Command output:

smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.15.60-1-MANJARO] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

Sending command: "Execute SMART Short self-test routine immediately in off-line mode".
Drive command "Execute SMART Short self-test routine immediately in off-line mode" successful.
Testing has begun.
Please wait 2 minutes for test to complete.
Test will complete after Wed Sep  7 14:45:48 2022 UTC
Use smartctl -X to abort test.

Output of the test using:

smartctl -l selftest /dev/sda


smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.15.60-1-MANJARO] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%      7293         -

Looks good.

Now, please open a terminal again, and try the chroot instructions as provided earlier, and reply if successful as well, please.

Whatever you do:
Do not run a command/commands in the terminal after completing the steps. Not even if it seems like something failed, as above.

The chroot ouput is same as in the 1/10 (start of the thread)

OK, something might be funky. Let’s test if you are, in fact, in a chroot environment. Please run the following:

grep ' / ' /proc/mounts


overlay / overlay rw,relatime,lowerdir=/run/miso/sfs/livefs:/run/miso/sfs/mhwdfs:/run/miso/sfs/desktopfs:/run/miso/sfs/rootfs,upperdir=/run/miso/overlay_root/upper,workdir=/run/miso/overlay_root/work,index=off,xino=off 0 0

That doesn’t look like a chroot environment to me. I’m officially all out of ideas. I’m going to have to call in reinforcements.

@bogdancovaciu @linux-aarhus @Fabby if you guys know what’s up, or have any idea at least, can you please, please, please tell us? So @faizan1191 can have a working PC, and I can learn something. If I can do that, I’ll mark today as a good day!

Initial guess is a faulty - likely an incomplete ISO - did you validate the downloaded file for completeness?

Yes i have verified the SHA1 checksum of the iso in use

I think I misunderstood something.

To get my understanding right

You synced your system - and after that sync - when rebooted you are greeted with the no kernel message.

Then you go the live iso way to rescue the system - but when when chrooting you get the quoted messages

The first error message is

This grub-probe error means nothing in relation to the automatic chroot

The second error message

This message indicates a file system error - likely a disk error - but could also be caused if the sync process being interupted by a power outage.

I have no clues to what you can do as that depends on the filesystem and how valuable the data may be on the disk.

If it is a filesystem error cause by a start-to-fail disk and If you have data you would like rescued - then any and all attempts from your side a likely to make the matter worse.

Replace the disk and reinstall your system and take the damaged to a professional data salvage shop. If you are a DIY linux user - you may play with testdisk and photorec and try if you can salvage anything from the damaged disk

Do your self a favor - never work the original.- but clone the damaged disk - then work on the copy.

If you have backup of your personal files or dtherwise don’t care - reinstall the system.

The sync process was not interrupted by a power outage as the device was connected to a stable power source throughout the process

Going ahead with reinstalling the system, thanks for the support :+1: @Mirdarthos @linux-aarhus