Yet another topic about unable to dual boot with Windows

Hi.

GRUB doesn’t show me my installation of Windows 10 as a boot option.

I’ve read some of the other topics but unfortunately I found no luck and I’m very scared of not screwing up my Windows boot.

Info and details:

  1. Running Manjaro Gnome on one SSD
  2. Running Windows on a seperate SSD.

Command outputs I ran:

os-prober: nothing (no output)

sudo parted -l
Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 250GB 250GB primary ext4 boot

Model: ATA ST1000DM003-1ER1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 1000GB 1000GB ntfs Basic data partition msftdata

Model: Viper M.2 VPN100 (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 1024GB 1024GB ntfs Basic data partition msftdata
4 1024GB 1024GB 531MB ntfs hidden, diag

Linux installed on the Samsung drive, Windows on the Viper nvme.

efibootmgr -v
EFI variables are not supported on this system.

sudo update-grub
[sudo] password for aleks: 
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I’m a bit surprised considering I had Manjaro before (before it broke to the point of no return) and it automatically added Windows as a boot option in GRUB.

Any help would be much appreciated! :slightly_smiling_face:

Hello @exo :wink:

No wonder Manjaro does not find windows. It was installed in BIOS mode. Grub will not search for efi partitions if it is installed this way.

You will need to install Manajro with EFI mode like you did with Windows.

1 Like

Thank you for the reply! I was suspecting that but I was unsure as I checked my Windows system status and it said UEFI under boot.

Is there anything I can do except reinstall? And how can I install Manjaro with EFI mode? Do I chose this somewhere in the installer?

Thank you I’m pretty new to this.

No not really, because a gpt partition table is needed and therefore everything on this hdd will be deleted anyway.

Depends on your UEFI. Best way to ensure it boots in UEFI mode is disabling legacy boot, CSM or however it is called, so that only UEFI is available at boot.

So if I inderstand this correctly it’s not dependant in any way of the USB or what image is flashed on there (in my case lastest Manjaro GNOME) but it’s purely based on HOW (what method) is used to boot into the live environment?

In short: YES

Manjaro can boot with BIOS or UEFI mode, but you have to set or choose the mode when booting the usb stick.

1 Like

Perhaps, if you like to experiment, before reinstalling, you could try gdisk. This tool promises mbr-> gpt conversion without data loss. Nevertheless this is a risky operation, but if you’ve decided to reinstall, it won’t really matter.

At first, you will have to create a fat32 partiton for the efi partition.

Right after that you will have to reinstall grub, because you will loose your bootloader.
Pay attention not to mess with your Windows. I would detach the Windows’ disk.

Please note: I’ve never tried this, but using gdisk seems very simple.

I have a super old Windows 10 install, and it’s an MBR (BIOS) partition, so I have trouble with this too. I don’t dual boot off of one disk anymore; I only use separate drives for OSes, but some Linux distros only recognize my computer is UEFI-capable if they boot in UEFI-only mode, which means that, to boot back into Windows, I have to re-enable legacy mode in the UEFI every time.

At some point, I should force myself to reinstall Windows 10 as a GPT partition; firmware formats only change once every 20 years or so. :pensive:

So I just found out I have Windows installed as MBR. So How would I go to install Linux? As EFI? I’m so so confused with all this … UEFI/EFI, MBR/GPT, …

@exo

I short:

  1. EFI needs a GPT partition table
  2. BIOS needs a MS-DOS partition table
  3. BIOS with a GPT partition table needs a extra 8MB bios-grub partition

If Windows is installed on a MS-DOS partition table, then it wrote the MBR (Master Boot Record).

If you need to install Manjaro on the same HDD/SSD as Windows, then the MBR will be overwritten by grub and grub will also add windows to the menu.

If you need to install on another HDD/SSD, then the MBR will be written on this drive, not on the windows one. But then you will need to change the boot order at your UEFI/BIOS so that the HDD/SSD of Manjaro boots first. In this case grub finds also windows and add it to its menu.

Hope that make it clearer…

According to this:

It is installed with a GPT partition table and EFI (it has a efi partition).

1 Like

Thank you @megavolt , you are corect.
My Windows has GPT and EFI, I assume I’m booting from UEFI then. I will disable safe / legacy Bios and try to reinstall Manjaro.

Also - I will edit the boot order so that it first boots from a UEFI USB FLASH DRIVE. Hopefully that helps.

Now I see that Manjaro has a MBR volume. Strange. No idea why it installed like that. :thinking:

Windows 10 can convert its partition from MBR to GPT without formatting and the good thing is that you don’t need to resort to third-party tools.

HERE there is a tutorial (but on Youtube you can find many video-tutorials).

If you’re using RUFUS to create a bootable USB drive on Windows make sure to change the default settings (which are for MBR)!

This is the reason why my Linux installation was MBR!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.