Yet another Manjaro/Win10 dual boot problem

Dear all,

Probably due to a wrong choice during installation I lost my Win10 boot capability. Details are here: previously on my laptop

Currently I can only boot to Manjaro, there seems to be no data loss.

My aim is to have a grub screen at startup to choose between Manjaro and Win10 to boot. Currently the laptop boots to Manjaro, I could not get it boot to Win10.

Any help is very much appreciated! Below there is the output of some of the commands usually asked for.

The output of update-grub:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.1-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-6.1-x86_64.img
Found initrd fallback image: /boot/initramfs-6.1-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi

The output of parted -l:

Model: ATA SAMSUNG MZ7LN512 (scsi)
Disk /dev/sda: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type      File system  Flags
 1      1049kB  577MB  576MB  primary   ntfs         boot
 2      577MB   247GB  246GB  primary   ntfs
 3      247GB   407GB  160GB  primary   ntfs
 4      407GB   512GB  105GB  extended               lba
 5      407GB   512GB  105GB  logical   ntfs

Model: ATA TS240GMTS420S (scsi)
Disk /dev/sdb: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2097kB  317MB  315MB   fat32                 boot, esp
 2      317MB   226GB  226GB   ext4            root
 3      226GB   240GB  13,7GB  linux-swap(v1)        swap

The output of efibootmgr:

BootCurrent: 0013
Timeout: 0 seconds
BootOrder: 0013,0009,000C,0007,0008,000A,000B,000D,0012
Boot0000  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0001  Boot Menu     FvFile(126a762d-5758-4fca-8531-201a7f57f850)
Boot0002  Diagnostic Splash Screen      FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0003  Lenovo Diagnostics    FvFile(3f7e615b-0d45-4f80-88dc-26b234958560)
Boot0004  Startup Interrupt Menu        FvFile(f46ee6f4-4785-43a3-923d-7f786c3c8479)
Boot0005  Rescue and Recovery   FvFile(665d3f60-ad3e-4cad-8e26-db46eee9f1b5)
Boot0006  MEBx Hot Key  FvFile(ac6fd56a-3d41-4efd-a1b9-870293811a28)
Boot0007* USB CD        VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot0008* USB FDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,6ff015a28830b543a8b8641009461e49)
Boot0009* ATA HDD0      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f600)
Boot000A* ATA HDD1      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f601)
Boot000B* ATA HDD2      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot000C* USB HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,33e821aaaf33bc4789bd419f88c50803)
Boot000D* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot000E* IDER BOOT CDROM       PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,1,0)
Boot000F* IDER BOOT Floppy      PciRoot(0x0)/Pci(0x16,0x2)/Ata(0,0,0)
Boot0010* ATA HDD       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f6)
Boot0011* ATAPI CD      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0012* PCI LAN       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,78a84aaf2b2afc4ea79cf5cc8f3d3803)
Boot0013* Manjaro       HD(1,GPT,4d7dcbd6-74f2-0246-8fac-3dc0c3f2452c,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)

Win was installed in ‘legacy’ mode, Manjaro in ‘uefi’. Try setting bios to ‘legacy’, then enter your bios’ boot menu (F8, F12?), pick the Samsung and you should boot straight to Win.

Not much wrong with this setup, in fact it has some advantages because Win updates will never mess up your grub. I’m ‘dual-booting’ the same way vice-versa because my Manjaro came from a bust legacy laptop. However, grub will not be usable as OS choser and you’ll have to set uefi/legacy every time you want to switch OS.

Tried this, but this gets me to a Majaro-themed grub menu without an option to boot into Win10.
Previously, with debian the grub-based choice worked well, this is what I’d like to achieve.

You sure your bios is set to ‘legacy’/‘CSM’? Grub sits on the fat32 partition of sdb1, at legacy boot of the Samsung drive your machine should pick the Win loader from mbr in sda.
If I boot ‘legacy’ it doesn’t even see the gpt drive.

:point_up_2: This.

You have two threads about the same issue running here.
Not good for helpers and for you keeping track of things suggested to you.

Yeah I just had the feeling that the install and the boot are separate problems.
I suggested the conversation to move over here in a message in the other thread.

My bad sorry for messing things up.

I doubt there is a real problem with ‘the install’. The only mistake was that you switched your legacy win laptop to uefi before installing manjaro.

Check your bios again, some bios just have ‘uefi = enabled/disabled’ options. Set to ‘disable’ to boot Win, set ‘enabled’ to boot manjaro.

I just checked the BIOS option “legacy only”.
This brings me to the grub rescue with the following error messages:
1.: no such device: → and the device ID listed
2.: unknown file system

the command set results:


the command ls results:

(hd0) (hd0, msdos5) (hd0, msdos3) (hd0, msdos2) (hd0, msdos1) (hd1)

It was unintentional. I must admit I wasn’t really aware of the differences between uefi and bios until earlier today.
Is there a fix for this issue?

If you just installed - and don’t want to fix the mismatch between the one system installed in bios mode and the other in UEFI mode
or don’t know how (I don’t, currently)
then the easy way would be to just reinstall - you just did it and it usually only takes ~half an hour …

This would be my approach.

I did actually install it again, I’m writing this from the working Manjaro system. I guess mixing things as they are now seems to be the worst option, but how can I force the Manjaro installer to go with the bios mode? If that works and I still feel adventurous I can move on the have UEFI uniformly.

As far as I know:
if you boot your system in bios mode - Manjaro will be installed matching that mode
if you boot your system in UEFI mode - Manjaro will be installed matching that mode

If Windows was installed in bios mode - choose that in the bios settings and then install Manjaro.
It seems intuitive to me. :man_shrugging:

Currently if I set legacy only and choose to boot from the iso I get to the grub rescue prompt with the following content:

I’m tempted to say:
of course

Of course Manjaro will not boot.
Install it in that same mode - not UEFI but the other one.

(both systems in the same mode)

Nope, don’t ‘set it to boot iso’, set it to boot the Samsung Win drive and there should be no grub, it should boot straight to Win.