Yay was able to upgrade while Pamac GUI wasn't

Paman log:

Synchronizing package databases...
Warning: dotnet-host-preview-bin: ignoring package upgrade (8.0.0.sdk100+preview.5-1 => 8.0.0.sdk100+preview.6-1)
Warning: dotnet-runtime-preview-bin: ignoring package upgrade (8.0.0.sdk100+preview.5-1 => 8.0.0.sdk100+preview.6-1)
Warning: dotnet-targeting-pack-preview-bin: ignoring package upgrade (8.0.0.sdk100+preview.5-1 => 8.0.0.sdk100+preview.6-1)
Checking dotnet-sdk-preview-bin dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building dotnet-preview-bin...
==> Making package: dotnet-preview-bin 8.0.0.sdk100+preview.5-1 (Fri Jul 21 09:45:32 2023)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> ERROR: dotnet.sh was not found in the build directory and is not a URL.
Failed to build dotnet-preview-bin

And then i run yay -Syu in the terminal, and everything was installed just fine.

Meaning pacman worked when pamac didnt … meaning it was likely the same issue as reported in the announcement thread and a few dozen others.

Oh wait. You mean just those AUR packages?

Also I was able to update other packages, only these stuck.

Run… :arrow_down:

sudo pkgfile -u

… and all will be fine again. :smiley:

1 Like

I pressed this, it is the same. Didn’t fix.

The problem was with pamac itself. You cannot fix pamac from within pamac. Use the command I gave you instead.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.