Yarn `create react-app app` hangs / network related

The above command hangs at Installing packages. This might take a couple of minutes stage.
npx create-react-app app command works if there’s no yarn installed(no matter if it’s through system repo or npm install -g yarn) if I install yarn it also hangs.
yarn 2.4.1 yarn dlx create-react-app app also doesn’t work.
Tried node v14.15.1 and v16.1.0, also tried nvm(the same thing occurs).
If I use mobile internet instead of my home Wi-Fi it works as expected. Factory-resetting Wi-Fi router didn’t help. I don’t use proxy or vpn.

yarn 1.22.10
npm 6.14.8

yarn config list

'version-tag-prefix': 'v',
'version-git-tag': true,
'version-commit-hooks': true,
'version-git-sign': false,
'version-git-message': 'v%s',
'init-version': '1.0.0',
'init-license': 'MIT',
'save-prefix': '^',
'bin-links': true,
'ignore-scripts': false,
'ignore-optional': false,
registry: 'http://registry.npmjs.org',
'strict-ssl': true,
'user-agent': 'yarn/1.22.10 npm/? node/v14.15.1 linux x64',
lastUpdateCheck: 1620817309015,
prefix: '/home/user/.yarn'
info npm config
registry: 'http://registry.npmjs.org/',
'http-proxy': null

Output of inxi:

Kernel: 5.10.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
root=UUID=3661bcba-2650-47fa-a8e3-095c98a16148 rw quiet 
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Manjaro Linux base: Arch Linux 
Type: Laptop System: HP product: HP ProBook 430 G5 v: N/A serial: <filter> 
Chassis: type: 10 serial: <filter> 
Mobo: HP model: 8377 v: KBC Version 02.3D.00 serial: <filter> UEFI: HP 
v: Q85 Ver. 01.11.01 date: 04/27/2020 
ID-1: BAT0 charge: 28.7 Wh (100.0%) condition: 28.7/28.7 Wh (100.0%) 
volts: 12.8 min: 11.4 model: Hewlett-Packard Primary type: Li-ion 
serial: <filter> status: Full 
RAM: total: 22.92 GiB used: 2.77 GiB (12.1%) 
RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
microcode: E0 cache: L2: 6 MiB bogomips: 28800 
Speed: 900 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
4: 900 5: 900 6: 900 7: 900 8: 900 
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
xsaves xtopology xtpr 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf 
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass 
mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 
mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 
v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300 
Device-2: Cheng Uei Precision Industry (Foxlink) Webcam type: USB 
driver: uvcvideo bus-ID: 1-6:2 chip-ID: 05c8:03b1 class-ID: 0e02 
serial: <filter> 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
loaded: modesetting display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
s-diag: 414mm (16.3") 
Monitor-1: eDP-1 res: 1366x768 hz: 60 dpi: 118 size: 293x164mm (11.5x6.5") 
diag: 336mm (13.2") 
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.0.3 
direct render: Yes 
Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
chip-ID: 8086:9d71 class-ID: 0403 
Sound Server-1: ALSA v: k5.10.34-1-MANJARO running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: yes 
Sound Server-4: PipeWire v: 0.3.26 running: yes 
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
vendor: Hewlett-Packard driver: r8168 v: 8.048.03-NAPI modules: r8169 
port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp1s0 state: down mac: <filter> 
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 3000 
bus-ID: 02:00.0 chip-ID: 8086:24fd class-ID: 0280 
IF: wlp2s0 state: up mac: <filter> 
IP v4: <filter> type: dynamic noprefixroute scope: global 
broadcast: <filter> 
IP v6: <filter> type: noprefixroute scope: link 
IF-ID-1: virbr0 state: down mac: <filter> 
IP v4: <filter> scope: global broadcast: <filter> 
IF-ID-2: virbr1 state: down mac: <filter> 
IP v4: <filter> scope: global broadcast: <filter> 
WAN IP: <filter> 
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
bus-ID: 1-7:3 chip-ID: 8087:0a2b class-ID: e001 
Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled 
rfk-block: hardware: no software: yes address: see --recommends 
Message: No logical block device data found. 
Device-1: luks-81dd90ee-c495-4b3a-ba33-7f66c22209aa maj-min: 254:0 
type: LUKS dm: dm-0 size: 183.09 GiB 
p-1: nvme0n1p4 maj-min: 259:4 size: 183.09 GiB 
Device-2: luks-4477e086-0f2f-42f1-85cb-de1aa4d96480 maj-min: 254:1 
type: LUKS dm: dm-1 size: 15.83 GiB 
p-1: nvme0n1p2 maj-min: 259:2 size: 15.83 GiB 
Message: No RAID data found. 
Local Storage: total: 704.24 GiB used: 562.75 GiB (79.9%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix 
model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB block-size: physical: 512 B 
logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
rev: 80000E00 temp: 33.9 C scheme: GPT 
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Toshiba model: MQ01ACF050 
size: 465.76 GiB block-size: physical: 512 B logical: 512 B 
rotation: 7200 rpm serial: <filter> scheme: GPT 
Message: No optical or floppy data found. 
ID-1: / raw-size: 39.06 GiB size: 38.2 GiB (97.79%) used: 23.99 GiB (62.8%) 
fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 label: Root 
uuid: 3661bcba-2650-47fa-a8e3-095c98a16148 
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
used: 20.2 MiB (4.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: EFI 
uuid: B316-502C 
ID-3: /home raw-size: 183.09 GiB size: 179.21 GiB (97.88%) 
used: 141.81 GiB (79.1%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
mapped: luks-81dd90ee-c495-4b3a-ba33-7f66c22209aa label: Home 
uuid: e999a6fe-897c-4a2e-9fa4-64a8a5065eef 
ID-4: /run/media/shgr/toshiba raw-size: 465.76 GiB size: 457.45 GiB (98.22%) 
used: 396.93 GiB (86.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: toshiba 
uuid: 7665dca9-6b07-472f-b5b4-a87ea7456ba8 
Kernel: swappiness: 1 (default 60) cache-pressure: 100 (default) 
ID-1: swap-1 type: partition size: 15.83 GiB used: 0 KiB (0.0%) priority: -2 
dev: /dev/dm-1 maj-min: 254:1 
mapped: luks-4477e086-0f2f-42f1-85cb-de1aa4d96480 label: Swap 
uuid: ac7da819-1726-4513-b313-77628304ce47 
Message: No unmounted partitions found. 
Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
Device-1: 1-6:2 info: Cheng Uei Precision Industry (Foxlink) Webcam 
type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
power: 500mA chip-ID: 05c8:03b1 class-ID: 0e02 serial: <filter> 
Device-2: 1-7:3 info: Intel Bluetooth wireless interface type: Bluetooth 
driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
chip-ID: 8087:0a2b class-ID: e001 
Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
chip-ID: 1d6b:0003 class-ID: 0900 
Device-1: 2-3:2 info: Toshiba America External USB 3.0 type: Mass Storage 
driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s chip-ID: 0480:b200 
class-ID: 0806 serial: <filter> 
System Temperatures: cpu: 44.0 C mobo: 0.0 C 
Fan Speeds (RPM): N/A 
Processes: 262 Uptime: 31m wakeups: 1 Init: systemd v: 247 tool: systemctl 
Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1816 lib: 441 
flatpak: 0 Shell: fish v: 3.2.1 running-in: yakuake inxi: 3.3.04 

EDIT: the same commands work on another laptop with Windows 10 using the same Wi-Fi, so the issue is not in a router.

What is the output network error of the YARN command?

Find in this thread, you may find the solution: https://github.com/yarnpkg/yarn/issues/4890

No error just hangs(increasing time trick doesn’t work already tried). yarn install works, it seems only the npx create-react-app app and yarn create react-app app commands fail to work.
Pretty much tried all the solutions on stackoverflow and github, none works.

If it helps here’s additional info:
6 months or so ago it all worked, didn’t touch web programming several months till recently, the only time I crashed my system is when I deleted the systemsettings package.

Created a new Manjaro user repeated the actions got an error, searched my user’s log and found the same error:

Error: https://registry.yarnpkg.com/create-react-app: ETIMEDOUT
at Timeout._onTimeout (/usr/lib/node_modules/yarn/lib/cli.js:141409:19)
at listOnTimeout (internal/timers.js:554:17)
at processTimers (internal/timers.js:497:7)

I do not think it’s Manjaro, if or it would notice it in other applications.
In the previous link, there are a lot of solutions.
In summary:

  • Delete any “*.lock” and rm node_modules. Or rm -rf node_modules/
  • Clean a flush all connections things like DNS, caches and so on.
  • Terminal commands:
    • set http_proxy=
    • set https_proxy=
    • yarn config delete proxy
    • npm config rm https-proxy
    • npm config rm proxy
    • npm config set registry "http://registry.npmjs.org" or npm config set registry "https://registry.npmjs.org"
    • Restart your terminal and Try.

I think that problem is not Manjaro. You should ask for help in the Nodejs forums: Issues · nodejs/help · GitHub

1 Like

I think these commands fixed it:
sudo systemctl start systemd-resolved
sudo systemd-resolve --flush-caches

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.