Yakuake/tilda/guake and passwdless sudo strangeness

Hi all –

I installed Manjaro on a spare laptop a few weeks back (I use arch on my main desktop/laptop). For the most part I’ve done little customization as I have worked to install my typical apps. So I’m on GNOME 40.4.0 at the moment.

Being used to Ubuntu and Arch, I’ve been trying to set things up in Manjaro to my normal baseline, which for the purposes of this posting is using a dropdown terminal and setting up passwordless sudo.

I rely a lot on a drop down terminal and mostly use yakuake. After installing it, however, I seem unable to activate it after it has opened and closed the first time. Same thing for tilda and guake. In all three cases when launched, the drop down appears as per normal. If I hit the appropriate key binding it goes away. After that, none of them activate again. I have tried various permutations of different bindings, not using FN keys, etc. It’s driving me to frustration.

Another “weirdness” (at least to me) is that passwordless sudo does not seem to work? For the sake of completeness we can skip any discussions about security etc. I am fully aware and yet I am fully choosing to have no password sudo. So yes, my user is in the wheel group and in my /etc/sudoers I have


However, sudo commands still persist in asking for my password.

Any help/pointers are much appreciated.

could it be that your config with sudoers is overwritten by the Manjaro default?


I think renaming your config to a higher value would do the trick e.g.


Oh, that seemed to be the issue. Renaming the file didn’t work, so I simply edited it directly to contain


Now if I can only figure out how to get the drop down terminals to work properly, I’d be mostly set!

Many thanks

Well - you are right - there is no need to have two files.

I was thinking about the order in which drop-in configs are loaded. They are usually loaded using an alpha-numeric sort - if the same configuration is defined twice - the higher file takes precedence - but that may not work entirely as I thought with sudoers.d.

And FWIW, I “fixed” the drop down yakuake and tilda issue. Seems that by default GNOME uses wayland. I switched to GNOME (x11) and all worked as expected. Also, I previously had a slight somewhat annoying screen brightness flutter (every now and again the screen would slightly dim and then return to original brightness – all within the space of a second). That seems better behaved, too, now.