Yakuake shortcut not always working in Plasma 6 Wayland / keep above other windows not working at all

Hello,

I have a problem with Yakuake after upgrading to Plasma 6, where the shortcut F12 does not always work. Using a custom shortcut does not help.

This seems to only happen when Yakuake is open, then loses focus and stays open in the background. Oddly it only seems to not work if I focus multiple other applications after each other. It sometimes seems to reappear after having only focused one other application.

Also I noticed that the option “Keep above other windows” does not work at all. When clicking any other window Yakuake loses focus and disappears.

I was able to find a solution for me by disabling “keep window open when it loses focus”. Now when I press the shortcut it reappears as if I had retracted it before.

I am using Wayland with three monitors on an Nvidia GPU using proprietary drivers.

Does anybody have an idea how to fix this?

Thanks!

1 Like

These are my Yakuake behaviour settings. Try them yourself and see if it suits you better. Oh, and remember to unpin the thumbtack button, otherwise the F12 toggle will not work as expected.

  • Open window after program start
  • Open window when the mouse pointer touches the screen edge
  • Keep window open when it loses focus
  • Keep window above other windows
  • Use Open/Retract action to focus window
  • Keep window open after the last session is closed
  • Focus terminals when the mouse pointer is moved over them
  • Remember and restore window fullscreen state
  • Show system tray
  • Confirm quit when more than one session is open

Additionally, you will likely want to add Yakuake to the list of programs in System SettingsAutostart.

I hope this helps. Cheers.

2 Likes

On Wayland, that option “Keep above other windows” doesn’t work because it needs more work to be done.
So it’s recommended to disable it.

It works as expected here. Is this the commit?:

If you enable that “Keep window open when it loses focus”, then it should be kept hidden behind after you click on other apps, and when you press F12 it will do nothing, because it can’t gain focus for itself on Wayland (it works in X11), so the second time you click on F12 it will grab it from above instead of simply giving it top focus.

1 Like

Well, that’s interesting; though it only seems to happen when the window is also pinned in place; a button I rarely use. When it’s pinned, Always on top doesn’t seem to be honoured at all. When it isn’t pinned, and with my configuration, I don’t notice it.

Thanks! This is what I need to know