Xterm missing default fonts

This question is similar to this topic:

After new installation of Manjaro
(installed via SD-boot, used this release,
and after additional installation of xterm,
xterm is missing default fonts.

xterm: cannot load font “-misc-fixed-medium-r-semicondensed–13-120-75-75-c-60-iso10646-1”

Adding fonts does not seem to help.
I have tried to follow suggested documents from topic mentioned above, but find myself
not understanding what to do to get the the default fonts xterm say is missing.

My expectation is, and the way installing xterm “always has worked before”, is that
installing xterm bring default fonts needed and install them so that they are
accessible by xterm.

Here I cannot choose any font, but seems to fallback to the
rather small one that xterm manage to find.
So, I claim xterm is broken in this release of Manjaro.

Because, when I press
cntrl right-mouse-button
within a xterm window and try
any of the default fonts in the list appearing, I immediately get this:
(At STDERR I guess, within the shell where I started xterm.)

Warning: Cannot convert string “-adobe-helvetica-bold-r-normal–-120-----iso8859-” to type FontStruct

Then, when actually selecting a font, like “Large”, I get this:

xterm: cannot load font “-misc-fixed-medium-r-normal–18-120-100-100-c-90-iso10646-1”

And “whatever I do” I still get the rather small font I got in the first place.

I realize, if I understood X better, the documentation pointed to above
should provide the answer. However, this type of issue to get xterm onto my computer
should be rather new as I have before only needed to add (install) xterm and this worked.

Please help, either by “repairing” xterm packaging or explain to me how to fix this.

By the way, Manjaro-xfce is my very favorite Linux distribution. Thank you all!

1 Like

After struggling with this for a while, I figured out the solution is to install xorg-mkfontscale, part of the xorg-apps group.

The problem is not in XTerm, but in the Xorg server itself. It expects to find a fonts.dir file in the font paths, which is not generated unless xorg-mkfontscale is installed.