Xrandr showing HDMI output as disconnected when it is not

Hey there,

I’m using manjaro i3 21.0.4 and my second monitor is not being detected as connected by xrandr (when infact it is). I know for a fact that there are no issues with my monitors or cables because I just tested them with windows 10 and elementary os 6 odin and both monitors are detected and work flawlessly.

I can’t seem to figure out why it works on another linux distro and not on manjaro. They’re both relatively new versions so I’m stumped.

I’m using an iGPU (with no discrete GPU), intel i5-11500 specifically. This CPU uses intel UHD graphics 750.

I seem to have the exact same issue as this user but no one has responded to their post yet:

(i can’t post links)


  • i’ve looked at a bunch of articles online but can’t find a solution that works for me. most are in reference to systems that use nvidia for graphics.
  • i also dont have a xorg.conf in /etc/X11/ for some reason

xrandr -q

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 480mm x 270mm
   1920x1080     60.00*+  50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1400x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-3 disconnected (normal left inverted right x axis y axis)

inxi -Fayz

  Kernel: 5.11.22-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64
    root=UUID=2623d0c2-c56e-4f28-b7e5-1686604c8f69 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: i3 4.20.1 info: polybar dm: LightDM 1.30.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: PRIME B560M-A v: Rev 1.xx serial: <filter>
    UEFI: American Megatrends v: 0820 date: 04/27/2021
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K330
    serial: <filter> charge: 10% (should be ignored) rechargeable: yes
    status: Discharging
  Info: model: 11th Gen Intel Core i5-11500 socket: LGA1200 bits: 64
    type: MT MCP arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
    microcode: 0x40
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 800 high: 801 min/max: 800/4600 base/boost: 2673/4600
    scaling: driver: intel_pstate governor: powersave volts: 0.8 V
    ext-clock: 100 MHz cores: 1: 800 2: 800 3: 800 4: 801 5: 800 6: 800 7: 800
    8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 65112
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: ASUSTeK
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:4c8a class-ID: 0300
  Device-2: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-10.2:9 chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  Display: server: X.Org driver: loaded: modesetting
    alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-1 res: 1920x1080 hz: 60 dpi: 102
    size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
  OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 21.3.4
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:43c8
    class-ID: 0403
  Device-2: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-10.2:9 chip-ID: 0c45:636b class-ID: 0102 serial: <filter>
  Sound Server-1: ALSA v: k5.11.22-2-MANJARO running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: no
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15fa class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Local Storage: total: 2.04 TiB used: 874.86 GiB (41.9%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    family: BarraCuda 3.5 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: HDD rpm: 7200
    serial: <filter> rev: 0001 temp: 33 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 65d 22h cycles: 308
    read: 3.38 TiB written: 3.81 TiB Pre-Fail: attribute: Spin_Retry_Count
    value: 100 worst: 100 threshold: 97
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G
    family: Driven SSDs size: 223.57 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.2 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: J4.3 temp: 27 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 65d 18h cycles: 310
    read: 1077 GiB written: 2824 GiB
  ID-1: / raw-size: 64.59 GiB size: 63.02 GiB (97.58%) used: 44.36 GiB (70.4%)
    fs: ext4 block-size: 4096 B dev: /dev/sdb5 maj-min: 8:21
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.3 MiB (26.3%) fs: vfat block-size: 512 B dev: /dev/sdb1
    maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: 27.8 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 349 Uptime: 1d 8h 50m wakeups: 89 Memory: 14.48 GiB
  used: 9.24 GiB (63.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1408 lib: 412 Shell: Bash (sudo)
  v: 5.1.16 running-in: sakura inxi: 3.3.12

All help would be appreciated, let me know if you want the output of any other command. Thanks!

Please post some more info about your system, like inxi -Fayz, for example. There might be an issue specific for your hardware.

Hi, thanks for the response. I’ve now updated the post.

5.11 is EOL. Switch to a supported kernel:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 
sudo mhwd-kernel -i linux515

Then reboot into 5.15 (Press Esc during boot to get into grub menu and boot with 5.15)
Double check your running kernel is not 5.11 then remove it:

uname -r #to check kernel version
sudo mhwd-kernel -r linux511

Thanks for the response.

I just installed the 5.15 kernel and tested it and my system does not boot. I selected the 5.15 kernel and then it said something like:

/dev/sdb5 ..... blocks

not exactly sure what it said but that is normal it happens even when I boot the old kernel. The problem is that it gets stuck after that.

I’ve actually had this problem in the past aswell. At one point I installed a newer kernel version and tried to boot it and the exact same thing happened. That’s why I’ve just been using 5.11.

Any ideas?

I have solved my problem! Someone on reddit helped guide me and I was able to fix the issue I was facing. Refer to the reddit post for more info: https://www.reddit.com/r/ManjaroLinux/comments/sgkokh/xrandr_showing_hdmi_output_as_disconnected_when/

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.