Xrandr says HDMI is disconnected for external monitor

I just installed video-hybrid-intel-nvidia-440xx drivers on my laptop yesterday, the installation was flawless and I didn’t face any issues with my laptop monitor. However, I’m unable to connect to my TV via the HDMI port. xrandr says it’s disconnected.

>>> xrandr -q | grep HDMI                                                    
HDMI-1 disconnected (normal left inverted right x axis y axis)

Here’s inxi

>>> inxi -Fazy                                                               
  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=56d77d09-dec0-4408-b59c-9e65207adba1 rw quiet apparmor=1 
  security=apparmor resume=UUID=8a55e655-a595-4619-847e-091f12bb98da 
  udev.log_priority=3 acpi_osi=! "acpi_osi=Windows 2009" 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Notebook v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 84F8 v: 08.11 serial: <filter> UEFI: AMI v: F.29 
  date: 07/17/2020 
  ID-1: BAT0 charge: 47.9 Wh condition: 52.7/52.7 Wh (100%) volts: 12.0/11.6 
  model: HP Primary type: Li-ion serial: N/A status: Discharging 
  Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 1087 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1100 2: 1100 
  3: 1100 4: 1100 5: 1100 6: 1100 7: 1100 8: 1100 9: 1100 10: 1100 11: 1100 
  12: 1100 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: Chicony HP Wide Vision HD type: USB driver: uvcvideo bus ID: 1-6:4 
  chip ID: 04f2:b56d 
  Display: x11 server: X.org 1.20.8 compositor: gnome-shell 
  driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 3000 bus ID: 03:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 585.00 GiB used: 20.47 GiB (3.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Samsung model: MZNLN128HAHQ-000H1 size: 119.24 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 3H3Q scheme: GPT 
  ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 023 scheme: GPT 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 6060 bus ID: 00:17.0 chip ID: 8086.282a rev: 10 
  ID-1: / raw size: 205.27 GiB size: 201.55 GiB (98.19%) 
  used: 20.47 GiB (10.2%) fs: ext4 dev: /dev/sdb4 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 
  System Temperatures: cpu: 45.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 340 Uptime: 12m Memory: 7.59 GiB used: 1.74 GiB (22.9%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1238 pacman: 1235 
  lib: 306 flatpak: 0 snap: 3 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.1.05 

On a sidenote, the same monitor works on windows(dual boot), and it used to work sort of before installing 440xx on Manjaro, however it used to be very laggy.

On intel+nvidia dual-gpu configurations the only “sufficiently working” way to access outputs of the nvidia gpu is to run Xorg on the nvidia gpu. For changing which gpu Xorg is running on, I recommend optimus-manager.

1 Like

Thanks, will check it out. My question is why is the HDMI port showing ‘disconnected’ now? I mean it was working when I didn’t have the hybrid driver and I still have intel graphics running,

>>> glxinfo | grep renderer                                                  
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) UHD Graphics 630 (CFL GT2)

If anything, the port should still work with the Intel driver… or am I missing something very obvious?

P.S: This is my first linux distro install ever(I’ve used linux but never installed it myself), please forgive me for being a noob.

That’s a “feature” of most modern laptops nowadays: the HDMI port is only run through the nVidia adapter to cut costs so you either have to go full nVidia without Intel (if the nVidia is cross-wired to the internal laptop screen as well, which is becoming a rarity as well) or use optimus-manager like @pobrn already said.


This is strange, though.

@mizumi Please start sudo dmesg -w, then connect HDMI cable, and then check if anything appears in the output. Please run xrandr -q and xrandr --listproviders as well.

Tried that, dmesg didn’t log anything when I connected the cable, but interestingly, when I tried to remove the cable it logged this:

[  304.724829] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device SONY TV (HDMI-0)
>>> xrandr --listproviders                                                
Providers: number : 2
Provider 0: id: 0x44 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 2 associated providers: 0 name:modesetting
Provider 1: id: 0x240 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0
>>> xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93    40.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
HDMI-1 disconnected (normal left inverted right x axis y axis)

That’s interesting, because I’ve observed this when I switch to Windows, my system auto shifts to Nvidia when it has to run drive HDMI port(As you said, the performance tab shows 0% usage for intel).

This is weird, why would something so trivial need such high level of manual configuration? smh.

  • Market dominance: Windows has 80+% market share so if you can have a Windows driver that makes that easy without the user noticing, who cares
  • Cost: If you can shave off 1$ per PC sold and you sell 1 million PCs, that’s money in the bank!


As your original question has been answered, I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Thanks, that does solve my question for now.


1 Like

Would still appreciate it if someone could explain what the logs indicate, @pobrn maybe?

~ >>> sudo dmesg | grep nvidia                                            [130]
[    2.044654] audit: type=1400 audit(1601307796.847:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=348 comm="apparmor_parser"
[    2.045772] audit: type=1400 audit(1601307796.847:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=348 comm="apparmor_parser"
[    2.054373] nvidia: loading out-of-tree module taints kernel.
[    2.054384] nvidia: module license 'NVIDIA' taints kernel.
[    2.062894] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    2.079104] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
[    2.079569] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[    2.079712] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    2.265564] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  440.100  Fri May 29 08:14:04 UTC 2020
[    2.267421] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    2.267422] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[    5.863065] nvidia 0000:01:00.0: Enabling HDA controller
[    7.703023] nvidia 0000:01:00.0: Enabling HDA controller
[  304.724829] nvidia-modeset: WARNING: GPU:0: Unable to read EDID for display device SONY TV (HDMI-0)

Leaving the entire log for Nvidia, just in case. Thanks in advance!

This is the only thing that seems suspicious. Can you test another HDMI cable/different monitor/TV? Can you test another operating system?

1 Like

I have tested the same monitor with the same HDMI cable on windows and it works perfectly with no hiccups…

>>> cat /etc/modprobe.d/mhwd-gpu.conf                     
## Generated by mhwd - Manjaro Hardware Detection
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
options nvidia "NVreg_DynamicPowerManagement=0x02"

Also I found this file earlier, might as well include it.

Do you have another HDMI cable and can you test that, please?


Unfortunately, no :slightly_frowning_face:
But the same HDMI cable works on Windows 10, so I’m positive that the cable is not faulty.

@pobrn I’ve tried optimus-manager, but I’m facing issues switching to nvidia :frowning:

I’ve created a new topic here would be extremely grateful if you can help. Thanks in advance!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.