Xrandr does not rotate screen

Previously, I was using xrandr as xrandr -o 1 or with 0, which rotated my screen. Now when I run it (new instalation of Manjaro 22.1 with GNOME), the command does nothing and finishes without an error. Changing 0/1 to left/right/normal also does nothing.

The automatic rotation works. Even if I turn it off with sudo systemctl stop iio-sensor-proxy, xarg still won’t rotate the screen.

I tried to look into manual and found that I should be able to also use this xrandr --output eDP-1 --rotate right, where eDP-1 is my screen name that I got from the last column in xrandr --listmonitors. This also does not work and gives me the following error:

  X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  7 (RRSetScreenSize)
  Serial number of failed request:  22
  Current serial number in output stream:  23

Most likely you are on wayland session where xrandr will not work.


Thanks, found alternative for xrandr - gnome-xrandr which works.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.