XPS 9370 Kernel Panic after installing any Manjaro flavour in UEFI mode

Due to my prior post which mentions that I could only see my full RAM in UEFI mode and in Legacy boot I had half the RAM - I decided to reinstall Manjaro but this time in UEFI.
I have spent two days turning on and off different BIOS settings, trying different USBs and ISOs and ensuring they aren’t corrupted via the checksum. All to no avail.

I have tried:

  • Ensuring Secure Boot is off
  • Not using RAID
  • Different USBs
  • Different ISOs
  • Ubuntu… (didn’t work either)

I can install after maybe 9 attempts, I get many different errors depending on when I turn on the machine. Often it gets into the boot up process from the Live USB and fails at one of many services such as the Network Manager, or Light DM. It fails a bunch of those sometimes, and others it goes through.

Below is a pic of what happens when I turn it on after “successfully” installing Manjaro i3

Another boot right after:

And one more…

I would understand if the problems were consistent… but it really can just change and aren’t purposely reproducable… I got into “emergency mode” and got a segfault after this

I will get you whatever diagnostic info you may be interested in… but at this point I’m starting to believe I have a hardware problem…

And now it says.

[FAILED} Failed to start Light Display Manager. Modem Manager[420]: <info> [base-manage] couldn't check support for device '/sys/devices/pci0000:00:1c.2/0000:02:00.0': not supported by any plugin.

I looked at your bios date and it looks really old. I would check with Dell and see if there is a newer version. I did simple search on your system and found a bios version dated 24 Sep. 2021. There are also chipset updates and drivers like that that may help. There are a lot of items marked urgent, including an Micron Nvme drive firmware update. I would install the chipset stuff, the bios update and certainly the Nvme firmware update. As a matter of fact I would probably install anything marked urgent. If you have a Windows license install it and run the installers and the wipe the drive and try again. I am assuming you will need Windows to install these updates.

1 Like

Thanks for the advice, for some reason I never really considered those things as I’ve never had to upgrade those things before.
I tried installing Windows 10 without a license, but it gets stuck in the installation process with random errors, and ends up in an infinite boot process when it does actually go all the way (Dell logo forever, tried leaving it overnight with no progress too).

I am going to see if I can make a legacy boot from a USB, if all ends up working smoothly then I will have a good inkling that there is something wrong with my 2nd ram module (which is soldered, so leaves me with a crippled machine regardless).

Thanks for the advice so far

I managed to install Manjaro i3 in legacy mode, of course it is only using half my RAM. Sadly the Light Display Manager fails to start so I cannot get in yet - but at least it is a different sort of problem.

I think I can tolerate only having half my RAM available since I don’t run hardcore IDEs on my laptop, but just VSCode and whatever project I’m working on at the time.

My laptop is XPS 9370 and I am using Manjaro KDE for quite a long time. No problem, everything works fine.

Yes, I was using Manjaro KDE before this for 3 years without issues too. Though at some point I guess my system stopped detecting the other RAM module on legacy boot. So I attempted to reinstall Manjaro with a UEFI boot, which has leds to these issues.

Currently still haven’t solved the light dm issue. Perhaps just unlucky, as I think the build quality of the Dell XPS 13 is quite good - not sure if it is economical to send it to Dell out of warranty to replace the mobo with soldered components…

Any now it has booted up after some graphical glitches a fresh install of Manjaro i3.
Will need to see what kind of things will need installing… hopefully I can do the updates @jbonez50 mentioned from Linux

Lightdm issue was solved by adding i915 to my early kms modules definition and rebuilding the images for those. As for the firmware updates, I’m not really sure how to progress there from a Linux PoV.
As long as I have a running system, not sure I care much anymore either to be honest.

This Dell laptop is supported by LVFS, so once booted, you can update all bios/UEFI with fwupdmgr.

To update your BIOS using Linux, try with a WindowsPE disk. HirensBootCD is one of the more popular ones. Use Ventoy or etcher, make a bootable USB and go for it.


I’m glad you got some of your issues resolved. I would check with Dell support and see if they have any Linux bios update tools. I know at one point they were supporting Linux on their hardware. At any rate it can’t hurt to check.