[XPS 15] Brightness and power buttons don't work


I recently got an issue with my Dell XPS 15 9560, where the brightness buttons (located on F11 and F12) and the power button doesn’t work until I either turn off the display or put the laptop to sleep by closing the lid or using the sleep combination FN+Insert.

Here are two journalctl logs from before and after doing the trick/workaround.

I tried reinstalling all packages found on the minimal live iso, but no luck so far.
I also tried upgrading to the 5.13 kernel, in case that would solve it, without success.

Hello, FPS

I’am maybe a solution. Use the next combination: Fn+Arrow High and Fn+Arrow Down

I hope to help. Guytoo

That doesn’t work. The Fn+Arrow High and FN+Arrow Low combinations work as expected, namely PgUp and PgDn.

Note that this bug doesn’t happen with the minimal live iso, so I think something got corrupted on my current setup.

I think install new, simply.

Very helpful mate. If you have more useful information, please do share it…

I fixed the issue, I cannot say with 100% guarantee that this is the fix, but I was messing around with the xorg config lately.

I regenerated the xorg config with Xorg :2 --configure in a separate TTY screen and used that config under /etc/X11/xorg.conf.
The brightness and power buttons work again.

Very good ! I keep this method to coast. I think writing a tutorial on this site for the others users because is a regular problem find here.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.