Xorg should be restarted to work properly after update


In the last update I the kernel 5.9 was installed and after that (and many other) update(s) I was not able to open any program via gui.

The error:
Cannot open display :0

I need to ctrl+alt+f4 and restart X via command line to make it work:

pkill -x X && startx

I do use a external monitor.
I downgraded to kernel 5.4, issue continues.

I have no clue of whats going on, any help please?

  Kernel: 5.4.101-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=ee1db449-6r35-4f3f-8br5-d4ecxc7c0pbf rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 23501M2 v: ThinkPad T430 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 23501M2 serial: <filter> UEFI: LENOVO 
  v: G1ETC2WW (2.82 ) date: 08/07/2019 
  ID-1: BAT0 charge: 43.6 Wh condition: 51.2/85.9 Wh (58%) volts: 11.5/10.8 
  model: SANYO XXXXXX type: Li-ion serial: <filter> status: Discharging 
  Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20760 
  Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 
  3: 1197 4: 1198 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 class ID: 0300 
  Device-2: Chicony thinkpad t430s camera type: USB driver: uvcvideo 
  bus ID: 1-1.6:4 chip ID: 04f2:b2da class ID: 0e02 
  Display: server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :2 screens: 1 
  Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 930x285mm (36.6x11.2") 
  s-diag: 973mm (38.3") 
  Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  Monitor-2: DP1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") 
  diag: 690mm (27.2") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.3.4 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  class ID: 0403 
  Device-2: Logitech Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1.2:3 chip ID: 046d:0a44 
  class ID: 0300 
  Sound Server: ALSA v: k5.4.101-1-MANJARO 
  Device-1: Intel 82500LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 6080 bus ID: 00:19.0 chip ID: 8086:1502 class ID: 0200 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 8205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 class ID: 0280 
  IF: wlp3s0 state: up mac: <filter> 
  Local Storage: total: 335.37 GiB used: 109.13 GiB (31.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 120 GB 
  size: 111.8 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 00RL scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SUV500MS240G 
  size: 223.57 GiB block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: SSD serial: <filter> rev: 56RI scheme: GPT 
  ID-1: / raw size: 100.12 GiB size: 98.05 GiB (97.93%) 
  used: 19.46 GiB (19.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 332 KiB (0.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2 
  ID-3: /home raw size: 120 GiB size: 117.62 GiB (98.01%) 
  used: 109.67 GiB (93.2%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 3 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda5 maj-min: 8:5 
  System Temperatures: cpu: 52.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 3635 
  Processes: 242 Uptime: 24m wakeups: 1 Memory: 11.53 GiB 
  used: 3.54 GiB (30.7%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1200 lib: 354 Shell: Zsh v: 5.8 running in: konsole inxi: 3.3.01 

Xorg log

Have you tried Kernel 5.10 LTS or Kernel 5.11?

I didn’t, it was working on kernel 5.4

Then please try those kernels to see if anything changes. Newer kernels could have fixes for your system.

Thanks but I just tried both versions, same issue. = /

I had a similar issue many months ago when I tried 5.9. I was running the plasma-git and kwin-git versions (I don’t know how that happened), not the default kde and there were some version mismatches that messed up X11. Re-installing kde was necessary for me.

Hi. I`m using the correct version of both packages, tried to update to kernel 5.11, same issue.
No protocol specified
Cannot open display “:1”


Setting a hostname apparently solved the problem.


Then set one if you don’t have one already:

hostnamectl set-hostname myhostname

Silly, yep.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.