Xorg removed files crash

I removed a bunch of files related to X11 in aim of setting up a tkg kernel as it wasn’t showing me a desktop. I thought X would just deal with me removing a few files but it completely broke it. It wasn’t working on tkg kernel and would now launch on my normal kernel (latest stable) but no keyboard or mouse meaning I can’t even switch to another tty. Can I be given a simple all fix for this by just reinstalling alice or bob or something? Also, if I try go into another kernel, I have been getting x server connection refused a tonne. I’ve tried regenerating a xorg.conf btw but no dice.
I’ve deleted:
IN /etc/X11
IN /usr/share/X11
Oh yh. I have proprietary nvidia drivers, amd cpu, tried without xorg.conf as well, xfce and no DM like lightdm.

Hi @basementdweller1,

You could always boot with a Live ISO and enter a chroot environment of your current installation. Once there you can reinstall X (xorg, in the repositories, I think.)

I’m not exactly sure of the commands, or if it’s the only way to do it, but that’s the general idea,

Hope this helps.


Take a look at this page. Maybe there’s something helpful there.

Edit 2:
According to the Manjaro wiki

To force a package to be installed even if it is already installed use pamac reinstall. For example:

pamac reinstall smplayer

So, IN THEORY it would be

sudo pamac reinstall xorg

But don’t take my word for it. Rather research and confirm it yourself.*

My system boots to basic tty where I can type commands. I have already tried reinstalling xorg and also tried following the info provided at link below but no effect (although I haven’t setup the flag but I don’t even know how).
https://www.reddit.com/r/archlinux/comments/ftazwg/accidentally_deleted_etcxorgconfd_keyboard_and/What is currently going through my head as only real solution is to install arch to another drive, configure to install some stuff I had before (mainly nvidia drivers and kernel) and copy over the files I fucked around with but I would rather not as that feels like a needlessly lengthy process.
link you provided on reinstalling everything sounds like it would take forever and seems quite destructive too. I’d rather avoid that at all costs.
for reinstalling xorg, I didn’t use pamac and just pacman instead like normal as there isn’t a point of pamac in most situations in my opinion.

To install some basic xorg you could run this

sudo pacman -Syu xorg-server xorg-server-common xorg-xinit xf86-video-intel xf86-video-nouveau xf86-video-vesa xf86-input-libinput xf86-input-evdev

Then proceed with an enviroment e.g. LXDE

sudo pacman -Syu lxde epdfview accountsservice gnome-keyring gnome-icon-theme gnome-icons-standard perl-file-mimeinfo xdg-user-dirs xdg-user-dirs-gtk xdg-utils

Some spice on LXDE

sudo pacman -Syu lxde-wallpapers manjaro-lxde-config manjaro-lxde-desktop-settings manjor-lxde-logout-banner matcha-gtk-theme manjaro-openbox-matcha papirus-icon-theme papirus-maia-icon-theme ttf-dejavu ttf-roboto xcursor-breeze

Then copy the content of /etc/skel to your user’s home (including hidden dot files)

cp /etc/skel/.* ~
1 Like

what? I already have xfce and I absolutely do not want lxde. Also your method is very bloated with installing intel crap when I have already said I have nvidia.

It is an example - and as you have otherwisse provided zero information - you cannot expect any comment to hit the proverbial nail.

You even specified xfce as non working.

Feel free to adjust accordingly.


Oh I thought I was clear. Let me repeat. I launch into a tty on my system and I can do whatever. When I launch xfce, it opens fine and my startup programs popup showing my system doesn’t hang but I have no keyboard or mouse input which therefore means I can’t switch to eg tty2. Xfce works but xorg has gone special mode so it makes it non-functional. It is x’s problem and not xfce’s problem.

I don’t understand.
edit: If you would like more information on my system, you are free to request it.

Here’s my error I found:

Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.

What Should I do? I found post at: [solved] Xorg won't load mouse driver/configuration / Newbie Corner / Arch Linux Forums
but his problem was only mouse. Not sure how to even implement his solution. Tried change to evdev but nothing happened. What am I missing?

To anyone who cares, I found a solution with method I thought prior. Obviously your method of solving may be better or only way but mine wasn’t too bad for my solution. I installed (not live) arch to a pen drive and installed similar packages such as same kernel, nvidia graphics drivers version (etc) and made a nvidia auto make xconfig run (can’t remember command for that one but not complex) and then copied files/folders I previously destroyed from same directories but from the pen drive install to another drive, ran my main machine with entering to tty and mounted that drive and copy pasted files, reboot and ta da! Not sure who will find this post in the future but I hope that may help you as my problem was a bit autistic. In hindsight, I should have made more complete backups rather than weekly ones of my /home so don’t forget to backup kids. I think that is the lesson I will take from this.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.