XORG (EE) No screens found error

Hello everyone!
I have an issue with boot. Today i was tried to install ootimus manager. I’m just open pamac and install package. I checked /etc/X11/xorg.config.d directory, but all is clear. I’ve tried to remove it, reinstall drivers with mhwd, but nothing helped.
What is interesting, wayland session works fine, by the way i need X session for work :frowning:

It’s hard to post screen shot, but i’ll try post some photos if needed

so after you installed optimus you cant boot?

Yes, what is fun, i had optimus previously, but decided to reinstall, cause dual monitors don’t work fine (bad idea, i know) :smiley:

you are saying you can boot with wayland?
so post output from:
find /etc/X11/ -name "*.conf"
pacman -Qs optimus

Optimus git page says to remove bbswitch, should i ty it?

yes bbswitch should be removed… also did you uncomment the lines in sddm.conf?

I confused bbswitch with bumblebee. Should i try to remove bbswitxh anyway?

I didn’t find this strings in sddm.conf

Attaching sddm.conf output

so they are not there…
remove the bbswithc:
pamac remove linux515-bbswitch linux510-bbswitch
systemctl reboot

It’s didn’t help :frowning:

so remove optimus:
pamac remove optimus-manager optimus-manager-qt
systemctl reboot

It didn’t hwlp to

May it can be useful, i noticed, that boot process stacks on

TPL System shoutdown/reboot

so not even uninstalling optimus helped?
post again output from:
find /etc/X11/ -name "*.conf"
pacman -Qs optimus

No any optimus giles here

so what remains is reinstalling drivers:
sudo mhwd -r pci video-hybrid-amd-nvidia-prime
sudo mhwd -r pci video-linux
install only linux:
sudo mhwd -i pci video-linux
systemctl reboot
you install the nvidia afterwards

startx returns same
mhwd -li show, that on only video-linux is installed

startx returns the same nouveau? thats the open source driver… so there is something messed up there… install the nvidia again:
sudo mhwd -a pci nonfree 0300