Xmod does disable mY ctrl keY


Event: time 1664022994.036581, type 1 (EV_KEY), code 29 (KEY_LEFTCTRL), value 2
Event: time 1664022994.036581, -------------- SYN_REPORT ------------
Event: time 1664022994.073251, type 1 (EV_KEY), code 29 (KEY_LEFTCTRL), value 2
Event: time 1664022994.073251, -------------- SYN_REPORT ------------
Event: time 1664022994.109921, type 1 (EV_KEY), code 29 (KEY_LEFTCTRL), value 2
Event: time 1664022994.109921, -------------- SYN_REPORT ------------
Event: time 1664022994.146584, type 1 (EV_KEY), code 29 (KEY_LEFTCTRL), value 2

MY laptop has a bad ctrl keY and it will randomlY start pressing the ctrl keY. Ive tried to disable it in the xmod settings and outright removed the line 29 nothing works. Is thier an waY to remove this keY on boot and quick Ive tried everY thing so far nothing works. thanks

I can ssh into the computer thats about it

Hi @Deathermind, and welcome!

Pleasse see

This is for Ubuntu, but it’ll work for Manjaro too, seeing as it’s Linux:




Hope it helps!



When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

Thanks for the tip

But I have tried those already but randomly it starts to do it again and sometimes restarting fixes it. Im coming from ubuntu where the above tips helped and had the command run every start up just incase. But for whatever reason it just breaks. If ctrl is spammed it makes my entire keyboarded unusable. To get it in the state its in now I had to take apart my macbook unplug the keyboard enable ssh and did the things above. then put it together. again it sorta works but its spotty (but for some reason way better) im wondering if thier is a more extreme way to disable it.


My sister spilt all over this laptop the Shift and FN dont work at all, Alt works like half the time and control just spams. My guess is that its unrelated to the spill and is a tear in the keyboard as ive taken the key off to examine. I traded my airpods to my sister as she couldnt disable keys in mac os and thier are no good keyboard replacements. Im kinda stuck with a really nice macbook but nearly useless due to this problem. Again cant replace the board :confused:

To pile on this I see this line now, its new for some reason. Its outputted every time I click any key.

gEvent: time 1664031448.781119, type 4 (EV_MSC), code 4 (MSC_SCAN), value 7000a

EDIT:when ctrl starts spamming again this line does not show up along with it.