Xinput will NOT display anything close to any devices I actually have

Hey, so I’ve been looking at so many different forums, and it looks the like problem I am running into is something about my hardware. I want to enable track pad while typing, and I’ve been trying xinput, but it will not list my track pad in its list. libinput will show my track pad and the properties, but I cannot edit using libinput, this only verifies that my track pad does exist on my system, just that xinput is not seeing it. When I enter the command xinput-list or just xinput it displays this in the terminal:

WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:15                     	id=6	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:15            	id=7	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer-gestures:15            	id=8	[slave  pointer  (2)]
⎜   ↳ xwayland-touch:15                       	id=10	[slave  pointer  (2)]
⎜   ↳ xwayland-tablet stylus:15               	id=11	[slave  pointer  (2)]
⎜   ↳ xwayland-tablet eraser:15               	id=12	[slave  pointer  (2)]
⎜   ↳ xwayland-tablet cursor:15               	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:15                    	id=9	[slave  keyboard (3)]

Every forum I have come across shows actual devices, not whatever this is. Sorry if this is a problem that is already solved or something dumb, but I’ve been trying to solve this for for over 2 hours now.

When sharing output please share the text itself.
Not images of the text.

For how to format things and other tips see this guide

It usually makes sense to also include some system information, ie;

inxi -Farz

As to your (original) issue;

Thats simple enough. An example:


Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "DisableWhileTyping" "0"

Sorry for not elaborating on this issue as well. It seems that the config file for xinput is also not functioning normally. Simply by going to /etc/X11/xorg.conf.d displays only 00-keyboard.conf while viewing it using vim. The issue may be linked to the emptiness of the file. I have tried repairing xorg before, but I am met with the same issue.

That explains something…

Wayland on Xfce is experimental at best …

The Xfce GitLab is tracking the milestone changes for Xfce 4.20. The Xfce 4.20 schedule remains “TODO” at this point.

Well … then you dont have any such configuration file.
You should create one with contents like shown above/in the link.

Also thank you for adding text output. :slight_smile:

I agree that if you are using wayland this could contribute to odd showings of xinput as well as should probably be avoided on xfce for now.

Have you tried starting an Xorg session ?

So Wayland will not work, because they haven’t worked on this yet? Even if I manually add files, it will still run using Wayland. Do I have to remove it? It installed with xorg, so there should be a lot of dependencies associated with it. Where could I look to find out how to workaround Wayland?

Perhaps you could describe what the actual problem is - the goal you want to achieve.
Your chosen path towards it might not be the best or even outright wrong.
Xfce4 normally does not start in “wayland mode” - you had to have done something to get to the current situation.
Of which we don’t know much at all
inxi -Fzay
gives system information.

I’m just going to paste the entire result for this command for pure analysis, and I can edit this to only show possible conflictions for forum organization later.
Running inxi -Fzay results with this:

  Kernel: 6.6.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=972909c8-17e3-4891-8f97-302e491541e2 rw quiet splash apparmor=1
    security=apparmor resume=UUID=76c81cd0-3dc6-47f2-99ba-f1e7b8b8fcfd
  Desktop: GNOME v: 45.4 tk: GTK v: 3.24.41 wm: gnome-shell
    tools: gsd-screensaver-proxy dm: GDM v: 45.0.1 Distro: Manjaro
    base: Arch Linux
  Type: Convertible System: HP product: HP EliteBook x360 1030 G2 v: N/A
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: HP model: 827D v: KBC Version 44.61 serial: <superuser required>
    part-nu: 2KX98US#ABA uuid: <superuser required> UEFI: HP v: P80 Ver. 01.14
    date: 01/22/2018
  ID-1: BAT0 charge: 37.4 Wh (80.6%) condition: 46.4/46.4 Wh (100.0%)
    volts: 12.0 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i7-7600U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm
    family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 900 min/max: 400/3900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 900 2: 900 3: 900 4: 900 bogomips: 23209
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: reg_file_data_sampling status: Not affected
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:5916 class-ID: 0300
  Device-2: Chicony HP HD Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:4 chip-ID: 04f2:b58f
    class-ID: 0e02
  Device-3: Chicony HP IR Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:5 chip-ID: 04f2:b58e
    class-ID: 0e02 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0x422d built: 2016 res: 1920x1080
    dpi: 166 gamma: 1.2 size: 293x165mm (11.54x6.5") diag: 336mm (13.2")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
    drv: iris inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 620 (KBL GT2)
    device-ID: 8086:5916 memory: 15.14 GiB unified: yes display-ID: :0.0
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:9d71
    class-ID: 0403
  API: ALSA v: k6.6.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 3a:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp58s0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel Bluetooth wireless interface driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9:6 chip-ID: 8087:0a2b
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 6 state: up address: <filter> bt-v: 4.2
    lmp-v: 8 status: discoverable: no pairing: no class-ID: 6c0000
  Local Storage: total: 476.94 GiB used: 47.52 GiB (10.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLW512HMJP-000H1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: CXY73H1Q temp: 28.9 C
    scheme: GPT
  ID-1: / raw-size: 459.59 GiB size: 451.3 GiB (98.20%) used: 47.52 GiB (10.5%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 17.06 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 48.0 C pch: 37.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.5 GiB used: 3.38 GiB (21.8%)
  Processes: 227 Power: uptime: 23h 55m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 5 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.19 GiB services: gsd-power,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: pm: pacman pkgs: 1354 libs: 382 tools: gnome-software,pamac,yay
    pm: flatpak pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.34

Now we know why you are in a wayland session.
You are using Gnome - and could switch between wayland and xorg before login.
But you tagged your post as Xfce4 (unless I was imagining things …).

xorg is just not the default - but you can switch to it somewhere on the login screen