Xfce4-power-manager fails to open

IDK if its after recent update but every time I try to open up Xfce-power-manager it does not opens up :face_with_diagonal_mouth:
In terminal

xfce4-power-manager  :heavy_check_mark:
Xfce Power Manager: Another power manager is already running

pacman -Qi xfce4-power-manager  :heavy_check_mark:
Name : xfce4-power-manager
Version : 4.16.0-3
Description : Power manager for the Xfce desktop
Architecture : x86_64
URL : xfce:xfce4-power-manager:start [Xfce Docs]
Licenses : GPL2
Groups : xfce4
Provides : None
Depends On : libxfce4ui upower libnotify xfce4-notifyd hicolor-icon-theme
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 3.60 MiB
Packager : Evangelos Foutras foutrelis@archlinux.org
Build Date : Thu 03 Jun 2021 09:23:59 AM +0545
Install Date : Mon 24 Jan 2022 12:38:17 AM +0545
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

I tried re-installing or searched same thing on the internet
Found Similar thread on Internet running Manjaro i3wm just like me but his issue was solved with the update…
Any one having issue like me ?

This is not an error, you want to run another instance of xfce4-power-manager whereas one is already running.
You have the documentation :


1 Like

Right !!

xfce4-power-manager -c

The setting pops up but can you suggest me why running it via normal way instead of terminal does not work ?
Is it some issue of some update or anything else ?

Also When I close the lid I see the session getting suspended but its not getting locked ?
I use default XFLOCK ( blur and black ) one for locking
Do you know where can you amend this setting ?

What do you call normal way ? Can’t you open it via Settings Manager ?

There are several possibilities :

  1. in Power Manager there is a tab “Security”, where you can check “Lock screen when system is going to sleep”

  2. You can also play with screensaver settings

  3. The last solution is to edit /etc/systemd/logind.conf and choose what you need :

HandleLidSwitch=lock – It will get locked when lid closed.
HandleLidSwitch=ignore – It won’t do anything.
HandleLidSwitch=poweroff – It will shut down your system
HandleLidSwitch=hibernate – It will hibernate

Then sudo systemctl restart systemd-logind.service

I use Manjaro-settings-manager but there isn’t any option like that referring to power management
I open Xfce4-power-manager via Dmenu but right now it’s not opening
Its opening via the terminal only after

xfce4-power-manager -c

I have set the option to suspend while on battery or when on power
And the behaviour is inconsistent
I mean sometime it suspends and sometime it does not
sometime it locks the screen and sometime it does not

I was just wondering why I am seeing these behaviour

I was referring to XFCE Settings Manager.

If you don’t have it, you have a big issue.
What ISO did you use to install your system ?

I don’t think I that in my machine

I don’t know what iso was it
but I went to i3 and downloaded normally using this link

I didn’t check the digital signature of the iso because didn’t feel like I would get man-in-the-middle attack…

Is there any way I can deal with this ?

I got it, there is few xfce apps in i3 version. So, your version is certainly good.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.