XFCE Window manager theme not being applied to Firefox


I’ve run into a problem that has stumped me, and so I’ve come to the forums for help.

I run the R9X-GTK 2 theme with XFCE because it has nice fat grab handles on three corners. I have just installed Manjaro on a laptop and all applications except Firefox have the R9X theme/style applied. I use Firefox a lot, and I would like to have usable grab handles on its window. (Telling me to just use keyboard is not a helpful response to this post. :upside_down_face:)

On all of my other installations all applications, including Firefox, get the theme. I’m only having this problem on this laptop.

Here is how I install the theme:

  1. I go to xfcd-look dot org and download the R9X-GTK2 theme.
  2. I change it’s name to end in tar.gz instead of tar.tar (appears to be some bug between the website and Firefox).
  3. I go to Settings > Appearance and Add the theme. Interestingly, it never shows up in the list on the Appearance Dialog, but it always becomes available in the Window Manager settings.
  4. I go to Settings > WindowManager and select the theme.

On every other machine (physical or virtual) that I follow this procedure on, I get the theme applied to all windows. On this laptop, Firefox is completely unadorned, but every other application I run has them.

Last night, I did a complete re-installation (from a disk with all linux partitions deleted), and had the same problem.

This morning I created a VM running Manjaro XFCE to check the steps again before posting, and Firefox is getting the theme on the VM.

Does anyone have ideas about why Firefox would not be getting the theme on my laptop?


Set the theme in Firefox to use the system theme.

Right-click the toolbar and choose “Customize Toolbar” from the popup menu.

Next… :arrow_down:

Hi ben75, That setting (use System Theme) is already applied.

Hello Aragorn, That was it! Thank you so much!

Of course it was something dead simple… :man_facepalming:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.