Xfce: Unlike click menu, toolbar terminal button does not call default teminal

Hello, I’d like to use one of the toolbar actions in thunar to open my default termial. Manjaro stable version offers this but does not open my selected custom emulator, instead, I get the XFCE terminal.

I opened an issue some time ago in the thunar gitlab and they indicate this could potentially be a distribution-specific issue. Their suggestion was to take a look at the custom actions that have been declared. I do not know how to do this.

Can someoe show me what they might be referring to?

How did you set it?

Settings → Default Applications → Utilities

Switch the default terminal here. Just tested in a VM and works.

If you want to go down the custom action path (with a menu entry when you right click on a folder) you can look here and here but changing default application is a more universal solution.

in Thunar menu select Edit > Configure custom actions… to show configuration of custom actions

If there is already a custom action to launch default Xfce terminal, command can be edited to launch another terminal emulator e.g for mate-terminal:

Change terminal from x-term to mate-terminal / General discussion / Xfce Forums

mate-terminal --working-directory=%f

Thunar custom actions are saved to user home folder ~/.config/Thunar/uca.xml

1 Like

My default terminal is set to terminator. This is what I want to bring up. In in spite of having it set, the default action that is available for the toolbar opens xfce ignoring my selection.

Maybe the default action should be to use the default terminal.

The accepted solution works fantastically, I just expected this option to work out of the box with the system configuration.

Thanks, this is exactly what I wanted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.