XFCE: Space bar not working-----not-HW-fail-sw-issue!

spacekeynotworking.
the
cursor
blink
like
key
is
pressed
but
no
space
is
made
in
no
app.
keyboard
reconnect
not
help

please
help

need
to
restart
any
particular
service?

thankyou

Purchase a new keyboard.

thanks,but-that-is-bad-advice-i-tried-my-nearly-new-backup-one-and-same-problem-even-different-port-not-helps…it-is-software-problem

is-there-any-file-responsible-for-mapping-the-keys-keyboard-shortcuts-system-global-level?

update:
Shift+spacebar
makes-the-space

maybe-issue-related-to-my-attempt-of-setting-keyboard-shortcuts-in-VLC-player.It-has-global-column(means-system-wide)?

What Manjaro flawor you are using?

When you go to TTY? with Ctrl+Alt+F4 ( goint back with Ctrl+Alt+F2 or F1) does the space not work there either?

1 Like

XFCE
spacebar-works-in-Ctrl+Alt+F4
when-return-back(Alt+F7)then-no-where-works…

You probably set the key variant wrong somewhere in the settings.

To remove and delete it I would look inside $HOME/.config/xfce4 ?

xfce4-keyboard-shortcuts.xml file somewhere?? $HOME/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml ?

and keyboard-layout.xml

After deletion try to relogin and see

1 Like

Thank you for helping to solve this issue @freed00m :slightly_smiling_face:
What helped was what you have suggested. Two commands:

cd;cd .config;mv ./xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml ./xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml_bak

sudo systemctl restart lightdm

but unfortunately the second command did bad thing - it not only reloaded xfce, but also closed all apps. I am wondering if i could use any better command which would keep apps running.
I have found also some other commands:

killall xfce4-panel
and then:
xfce4-panel & disown

Hmm, that’s really not possible with lightdm, it running the graphical environments and when you reload it, all graphical apps dies.

I think that this is caused by VLC player and Clementine app (and maybe other that using XFCE system keyboard shortcuts):
It is Clementine app. If you are on XFCE, go to Clementine settings, click Configure Shortcuts. Then click to change key for the “Pause” to: spacebar or P
Then the one you set will stop working in all apps…

Version : 1.4.0rc1-3
Description : A modern music player and library organizer
URL : https://www.clementine-player.org/

UPDATE: same happened for VLC. When i removed “p” shortcut key in its settings and killed VLC, then “p” key started typing. I think it is about global keyboard shortcuts in VLC, VLC has to be restarted to unload previous app-wide shortcut and then add new one. Is confusing.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.