Xfce panel bugs with opacity set to anything else than 0

I was trying to reduce the panel opacity, but I found that the panel starts to duplicate the image of itself.
The panel with default style:

The panel with opacity 0:

If I close the panel settings window:

I tried to change the theme, but it didn’t work. So, I want help with this issue, I don’t this is a bug of the Xfce Panel itself, maybe it’s related to some system configuration.

P.S.: There is another issue with the panel, but it’s not related to opacity. When I open the panel settings window, it actives a highlight to the selected panel, but it remains even if I close the window:

So I have to open the panel settings again and close before it highlights the panel.

What works for me is i logout/login each time a made a change with panel opacity, otherwise i have weird behaviour like you.

Also, you can make some tests with an opaque background color to see what happens, yours seems to be transparent.

1 Like

I did logout and login and worked. Thank you! I think I had to try something like this before asking on the forum.

Even in case you find a solution yourself, please do post it in the forum so that others can know about it.

1 Like

Yes, there may be other people searching solutions for the same problem. Now I think this may be really a Xfce Panel bug.

1 Like

I also have this occur when I change panel transparency settings, etc. It seems to me that XFCE 4.16 isn’t very polished and does have a lot of bugs to work out.

This not the place here nor the subject of this topic to count the number of XFCE issues or whatever DE, it’s pointless and a waste of time.
There are many DE available if you are not happy with one of them.


i had almost the same problem, with panel not changing to transparent. The transparrent / oppacity control did nothin. Got it to work by changing the panel position.

Login and logout did nothing for me either.

Please write your own topic, because your problem is different here. And give more details with screenshots.

You have global menu (vala) installed, wich tends to be buggy. The solution is to sort this out first. There is no bug with opacity in xfce panel.

Never said I wasn’t happy with it, did I? Nope. Don’t think so.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.