XFCE Nvidia Desktop and all videos stutter every second

I bought a new graphics card, an Nvidia RTX 4070 Ti, in January. Since then I have the problem that my entire XFCE desktop has a short “stutter” every second. This is especially noticeable when playing videos (local or via browser), but I also notice these dropouts when scrolling slowly through a web page or moving a window across the screen. With Youtube videos I have about 10% dropped frames. It makes no difference if I use Chromium or Firefox.

As soon as I replace the graphics card with my old GTX 1050 Ti, I no longer have these issues. So there must be a connection with the graphics card. I was hoping that some driver update or a new Linux kernel would help, but so far nothing has happened. Although I have already looked around on the Internet in many possible places, I have not come across any comparable symptoms. Since the RTX 4070 Ti runs completely smoothly under Windows (dual boot), I assume that it is not a hardware defect.

Do you have any idea where to start fixing this issue? If you need any further information please let me know.

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 6.2.7-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.2-x86_64
    root=UUID=db0e859f-844d-4cbd-959b-5ff95fea1816 rw rootflags=subvol=@
    ibt=off quiet splash apparmor=1 security=apparmor udev.log_priority=3
  Console: pty pts/0 DM: LightDM v: 1.32.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MAG B660M MORTAR WIFI (MS-7D42) v: 2.0
    serial: <filter> UEFI: American Megatrends LLC. v: A.70 date: 08/31/2022
  Message: No system battery data found. Is one present?
  RAM: total: 31.05 GiB used: 3.08 GiB (9.9%)
  Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: Controller0-DIMMA1 type: no module installed
  Device-2: Controller0-DIMMA2 type: DDR5 detail: synchronous size: 16 GiB
    speed: 5400 MT/s volts: curr: 1.25 min: 1.1 max: 1.25 width (bits): data: 64
    total: 64 manufacturer: Kingston part-no: KF552C40-16 serial: <filter>
  Device-3: Controller1-DIMMB1 type: no module installed
  Device-4: Controller1-DIMMB2 type: DDR5 detail: synchronous size: 16 GiB
    speed: 5400 MT/s volts: curr: 1.25 min: 1.1 max: 1.25 width (bits): data: 64
    total: 64 manufacturer: Kingston part-no: KF552C40-16 serial: <filter>
  Info: model: 12th Gen Intel Core i9-12900KS socket: U3E1 bits: 64
    type: MT MCP arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 2
    microcode: 0x26
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 30 MiB desc: 1x30 MiB
  Speed (MHz): avg: 2865 high: 4722 min/max: 800/5200:5500
    base/boost: 4653/5500 scaling: driver: intel_pstate governor: powersave
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 801 2: 798 3: 801 4: 801 5: 795
    6: 801 7: 1513 8: 1900 9: 4700 10: 4722 11: 4700 12: 4700 13: 4700 14: 4700
    15: 4700 16: 4722 bogomips: 109392
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pconfig pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep
    smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
    tm tm2 tme tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA AD104 [GeForce RTX 4070 Ti] driver: nvidia v: 525.89.02
    alternate: nouveau,nvidia_drm non-free: N/A status: unknown device ID pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: none off: DP-1 empty: DP-2,DP-3,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:2782 class-ID: 0300
  Display: x11 server: X.org v: compositor: xfwm driver: X:
    loaded: nvidia gpu: nvidia,nvidia-nvswitch tty: 110x35
  Monitor-1: DP-1 model: Idek Iiyama PL2770QS serial: <filter> built: 2021
    res: 2560x1440 dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23")
    diag: 685mm (27") ratio: 16:9 modes: max: 2560x1440 min: 640x480
  API: OpenGL Message: GL data unavailable in console and glxinfo missing.
  Device-1: Intel Alder Lake-S HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 1-3.4:8
    alternate: snd_sof_pci_intel_tgl chip-ID: 0c76:1469 class-ID: 0300
    bus-ID: 00:1f.3 chip-ID: 8086:7ad0 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1
    chip-ID: 10de:22bc class-ID: 0403
  Device-3: JMTek LLC. KLIM Talk type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.2.7-2-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 04:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 2500 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-14:6
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Device-1: VG: vg_WD_BLACK_SN770_2TB type: LVM2 size: 1.6 TiB free: 1.21 TiB
  LV-1: lv_steam maj-min: 254:0 type: linear dm: dm-0 size: 400 GiB
  p-1: nvme0n1p4 maj-min: 259:4 size: 1.6 TiB
  Device-2: luks-c2fad7dd-0c38-402d-af84-89bd904f4777 maj-min: 254:1
    type: LUKS dm: dm-1 size: 150 GiB
  p-1: nvme0n1p3 maj-min: 259:3 size: 150 GiB
  Message: No RAID data found.
  Local Storage: total: 3.17 TiB lvm-free: 1.21 TiB used: 740.39 GiB (22.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WD BLACK SN770 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 731100WD temp: 45.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: TR150 size: 447.13 GiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 12.3 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 033 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 70 GiB size: 70 GiB (100.00%) used: 17.93 GiB (25.6%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: db0e859f-844d-4cbd-959b-5ff95fea1816
  ID-2: /boot/efi raw-size: 1024 MiB size: 1022 MiB (99.80%)
    used: 612 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: N/A uuid: 564C-1197
  ID-3: /home raw-size: 150 GiB size: 150 GiB (100.00%)
    used: 88.51 GiB (59.0%) fs: btrfs block-size: 4096 B dev: /dev/dm-1
    maj-min: 254:1 mapped: luks-c2fad7dd-0c38-402d-af84-89bd904f4777 label: N/A
    uuid: 7ea1d66c-055c-4331-8413-79364c25c818
  ID-4: /mnt/1TB_Festplatte raw-size: 931.5 GiB size: 931.5 GiB (100.00%)
    used: 631.4 GiB (67.8%) fs: ntfs block-size: 4096 B dev: /dev/sdb2
    maj-min: 8:18 label: MX500 uuid: 86CCDF14CCDEFD7D
  ID-5: /mnt/balder/alex raw-size: N/A size: 1.81 TiB
    used: 667.37 GiB (36.0%) fs: nfs4 remote: balder:/Alex
  ID-6: /mnt/balder/fotos raw-size: N/A size: 1.81 TiB
    used: 667.37 GiB (36.0%) fs: nfs4 remote: balder:/Fotos
  ID-7: /mnt/balder/spiele raw-size: N/A size: 1.81 TiB
    used: 667.37 GiB (36.0%) fs: nfs4 remote: balder:/Spiele
  ID-8: /mnt/steam raw-size: 400 GiB size: 400 GiB (100.00%)
    used: 2.54 GiB (0.6%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: vg_WD_BLACK_SN770_2TB-lv_steam label: N/A uuid: N/A
  ID-9: /var/cache raw-size: 70 GiB size: 70 GiB (100.00%)
    used: 17.93 GiB (25.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2 label: N/A uuid: db0e859f-844d-4cbd-959b-5ff95fea1816
  ID-10: /var/log raw-size: 70 GiB size: 70 GiB (100.00%)
    used: 17.93 GiB (25.6%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2 label: N/A uuid: db0e859f-844d-4cbd-959b-5ff95fea1816
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 1 GiB fs: vfat label: N/A uuid: B408-89F6
  ID-2: /dev/sda2 maj-min: 8:2 size: 529 MiB fs: ntfs
    label: Wiederherstellung uuid: 0CA24932A2492216
  ID-3: /dev/sda3 maj-min: 8:3 size: 100 MiB fs: vfat label: N/A
    uuid: 3E4A-8AA6
  ID-4: /dev/sda4 maj-min: 8:4 size: 16 MiB fs: N/A label: N/A uuid: N/A
  ID-5: /dev/sda5 maj-min: 8:5 size: 60 GiB fs: ntfs label: Windows
    uuid: D458DE7A58DE5AB6
  ID-6: /dev/sda6 maj-min: 8:6 size: 5 GiB fs: swap label: N/A
    uuid: 45180032-570f-4638-8011-31cbc13bda96
  ID-7: /dev/sda7 maj-min: 8:7 size: 60 GiB fs: btrfs label: N/A
    uuid: f0e232e5-7e84-41d0-a5e6-cfdd2fbc2b28
  ID-8: /dev/sda8 maj-min: 8:8 size: 146.13 GiB fs: ntfs label: Programme
    uuid: ACDEE4F4DEE4B82A
  ID-9: /dev/sda9 maj-min: 8:9 size: 100 GiB fs: btrfs label: N/A
    uuid: e4374688-b488-420e-876f-0cef9752027a
  ID-10: /dev/sdb1 maj-min: 8:17 size: 16 MiB fs: N/A label: N/A uuid: N/A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: Micro Star MYSTIC LIGHT type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 1462:7d42 class-ID: 0300 serial: <filter>
  Hub-2: 1-3:3 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-3.1:5 info: Holtek USB-HID Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04d9:0296 class-ID: 0300
  Device-2: 1-3.2:7 info: Pixart Imaging Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 093a:2521 class-ID: 0301
  Device-3: 1-3.4:8 info: JMTek LLC. KLIM Talk type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 0c76:1469 class-ID: 0300
  Hub-3: 1-11:4 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-14:6 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-4: 2-0:1 info: Super-speed hub ports: 9 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 2-2:2 info: Genesys Logic USB3.2 Hub ports: 4 rev: 3.2
    speed: 10 Gb/s chip-ID: 05e3:0625 class-ID: 0900
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 29 C
  Fan Speeds (RPM): N/A
  Processes: 395 Uptime: 21m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1144 libs: 356 tools: pamac,pikaur pm: flatpak pkgs: 0 Shell: Bash (su)
  v: 5.1.16 running-in: pty pts/0 inxi: 3.3.25
cat /etc/X11/mhwd.d/nvidia.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 525.85.05

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

pacman -Qs nvidia
local/egl-wayland 2:1.1.11-3
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.5-1
    Nvidia VDPAU library
local/lib32-nvidia-utils 525.89.02-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 525.89.02-1
    NVIDIA NV-CONTROL X extension
local/linux515-nvidia 525.89.02-12 (linux515-extramodules)
    NVIDIA drivers for linux
local/linux61-nvidia 525.89.02-11 (linux61-extramodules)
    NVIDIA drivers for linux
local/linux62-nvidia 525.89.02-9 (linux62-extramodules)
    NVIDIA drivers for linux
local/mhwd-nvidia 525.89.02-1
    MHWD module-ids for nvidia 525.89.02
local/mhwd-nvidia-390xx 390.157-1
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.161.03-2
    MHWD module-ids for nvidia 470.161.03
local/nvidia-utils 525.89.02-1
    NVIDIA drivers utilities
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

Things I tried in the last days:

  • Mainboard BIOS update
  • Reset all BIOS settings
  • Disable rBar
  • Change PCIe Link to Gen1
  • Change display cable from DP to HDMI
  • Tried different display refresh rates
  • Tried an older Linux Kernel (5.15)

Do you have any other ideas?

Best regards


did you reinstalled (and removed the config) drivers? or you just replaced the cards and use the same drivers? maybe it could help

Probably this problem occurs?

CPU throttling reducing memory bandwidth on IGP systems

For some models of CPU, the CPU throttling technology may affect not only CPU core frequency, but also memory frequency/bandwidth. On systems using integrated graphics, any reduction in memory bandwidth will affect the GPU as well as the CPU. This can negatively affect applications that use significant memory bandwidth, such as video decoding using VDPAU, or certain OpenGL operations. This may cause such applications to run with lower performance than desired.

To work around this problem, NVIDIA recommends configuring your CPU throttling implementation to avoid reducing memory bandwidth. This may be as simple as setting a certain minimum frequency for the CPU.

Depending on your operating system and/or distribution, this may be as simple as writing to a configuration file in the /sys or /proc filesystems, or other system configuration file. Please read, or search the Internet for, documentation regarding CPU throttling on your operating system.


So the new RTX 4070 needs more bandwidth as the GTX 1050, but is limited by the governor of the CPU? I could imagine that this could lead to stutter.

As I see your CPU has a iGPU: Intel® Core™ i9-12900KS Prozessor

I completely reinstalled the whole system including all drivers a few weeks ago on a new SSD. Unfortunately this didn’t change the behavior.

I changed the CPU govenor with the following commands for all CPU cores to performance. Sadly the stutters are still present.

[manjaro ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
[manjaro ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
performance powersave
[manjaro ~]# echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
[manjaro ~]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Interestingly audio seems not to be affected by these stutters. I can listen to my music without any problems.

Best regards


Hi @Sonyfreak,

Please provide the output for: :point_down:

mhwd --list

…and :point_down:

mhwd --listinstalled

Hey Mirdarthos,

[manjaro ~]# mhwd --list
> 0000:01:00.0 (0300:10de:2782) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

[manjaro ~]# mhwd --listinstalled
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
          video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!

Best regards,


I finally found the reason for the stutters. I’m using conky and there I monitor the GPU temperature and fan speed.

${template1 GPU\ Temperatur} ${template3}${exec nvidia-smi | grep "|*%" | awk '{print $3}' | cut -c1-2}°C
${template1 GPU\ Lüfter}     ${template3}${exec nvidia-smi | grep "|*%" | awk '{print $2}'}

As soon as I commented out those lines, the stutters were gone, too. :unamused:

I still don’t know why this never was a problem with past graphics cards (GTX 1080, RTX 2080 SUPER, GTX 1050 ti), but I’m glad I got rid of this annoying problem.

Best regards,


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.