XFCE manjaro with no sound at all

Maybe a step too far… :flushed: , first try booting manjaro or any other popular distro like Mint from usb and see if the sound works on the live system.

1 Like

Pipewire and Pulse Audio both running? I only have Pulse running here on Manjaro and also on a fresh install (xfce) this past weekend Pulse was default, though my .iso may not have been the most current.
I have EndeavourOS in a VM and xfce there runs pipewire by default and inxi ( for Audio) looks like:

  Device-1: Intel 82801AA AC97 Audio driver: snd_intel8x0 v: kernel
  bus-ID: 00:05.0 chip-ID: 8086:2415 class-ID: 0401
  Sound Server-1: ALSA v: k5.19.10-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes

Is sof-firmware installed?

Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
root=UUID=978bc290-46ff-45f3-83ed-585ebe0eeae0 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: Positivo Tecnologia SA product: Harrison v: N/A
serial: Chassis: type: 10 serial:
Mobo: Positivo Tecnologia SA model: N14DP7-V2 v: 11173397
serial: UEFI: N/A v: 1.12.X date: 06/30/2021
ID-1: BAT0 charge: 35.5 Wh (95.9%) condition: 37.0/37.0 Wh (100.0%)
volts: 8.1 min: N/A model: WB SR 1 WB Lion Battery type: Li-ion
serial: status: discharging
RAM: total: 3.65 GiB used: 2.1 GiB (57.4%)
RAM Report: permissions: Unable to run dmidecode. Root privileges
Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 8
microcode: 0x20
Topology: cpus: 1x cores: 2 smt: cache: L1: 112 KiB
desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 1518 high: 2224 min/max: 800/2800 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 813 2: 2224
bogomips: 4378
Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc
cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
flexpriority fpu fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida intel_pt
lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc
nopl nx pae pat pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse
pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap
smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vme vmx vnmi vpid
x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
Device-2: SunplusIT MTD camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-8:4 chip-ID: 735f:2223 class-ID: 0102 serial:
Display: x11 server: X Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: AU Optronics 0x2e3c built: 2013 res: 1366x768
hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
ratio: 16:9 modes: 1366x768
Message: Unable to show GL data. Required tool glxinfo missing.
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
driver: sof-audio-pci-intel-apl
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 1-8:4
chip-ID: 735f:2223 class-ID: 0102 serial:
Device-2: SunplusIT MTD camera type: USB driver: snd-usb-audio,uvcvideo
Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: yes
Sound Server-4: PipeWire v: 0.3.56 running: yes
Message: No PCI device data found.
IF-ID-1: wlp0s21f0u7i2 state: up mac:
IP v4: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: link
Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB
driver: btusb,rtl8xxxu bus-ID: 1-7:3 chip-ID: 0bda:b720 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Message: No logical block device data found.
Message: No RAID data found.
Local Storage: total: 119.24 GiB used: 8.77 GiB (7.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda maj-min: 8:0 vendor: BIWIN model: C6370 128GB
size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 1A0 scheme: GPT
Message: No optical or floppy data found.
ID-1: / raw-size: 109.18 GiB size: 106.91 GiB (97.92%) used: 8.77 GiB (8.2%)
fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
uuid: 978bc290-46ff-45f3-83ed-585ebe0eeae0
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
(0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
uuid: 18B4-04C9
Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 9.77 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
uuid: bc13589c-7592-4fb0-8c71-43ee825c5167
Message: No unmounted partitions found.
Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 1-4:2 info: Wacom CTL-490 [Intuos Draw (S)] type: HID,Mouse
driver: usbhid,wacom interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 498mA
chip-ID: 056a:033b class-ID: 0301
Device-2: 1-7:3 info: Realtek RTL8723BU 802.11b/g/n WLAN Adapter
type: Bluetooth driver: btusb,rtl8xxxu interfaces: 3 rev: 2.1
speed: 480 Mb/s power: 500mA chip-ID: 0bda:b720 class-ID: e001
Device-3: 1-8:4 info: SunplusIT MTD camera type: Video,Audio
driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
power: 500mA chip-ID: 735f:2223 class-ID: 0102 serial:
Hub-2: 2-0:1 info: Super-speed hub ports: 7 rev: 3.0 speed: 5 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 196 Uptime: 11m wakeups: 1 Init: systemd v: 251
default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
Packages: pacman: 1080 lib: 324 flatpak: 0 Shell: Bash v: 5.1.16
running-in: xfce4-terminal inxi: 3.3.20


i tested with win10 - initially the sound wasnt working but, after 15min, the system found the driver automatically, so, it is not my machine.

what can I do now? i want to use manjaro xfce…

Great, swap is fixed and you should have a stable system.

About the sound; searched for: arch linux Intel Celeron/Pentium Silver Processor High Definition Audio driver: sof-audio-pci-intel-apl at DuckDuckGo

This looks like the fix: No sound on Gemini Lake / Laptop Issues / Arch Linux Forums

PS: If you post terminal in/output please edit like that:


could you tell me exaclty what a i need to do?, i’m really a noob

First install alsa-ucm-conf and sof-firmware (which you said was already installed).

“Managed to fix it. I just changed my default sound card on ~/.asoundrc as the mic of the webcam is recognized as another sound card and is selected as default.”

  • change default sound card on home/.asoundrc — have a look at the options there
1 Like

both are installed already

home/.asoundrc i search for this file on etc and home, and config, and usr/share/alsa.

didn’t find it :frowning:

Well, back to the search for now: arch linux Intel Celeron/Pentium Silver Processor High Definition Audio driver: sof-audio-pci-intel-apl at DuckDuckGo

One more thing since it’s a new machine; check for available bios updates. https://www.meupositivo.com.br/para-voce/suporte-tecnico/drivers?txtNumeroSerie=N14DP7#numeroSerie

i found asound on manjaro repo. and installed.
so… i found the asound config and change the default sound card to from “microphone” to “pulse audio”.

now i’m trying to run these commands

amixer cset name=‘Headphone Switch’ on
amixer cset name=‘Speaker Switch’ on
amixer cset name=‘Headphone Playback Volume’ 3,3
amixer cset name=‘Right Headphone Mixer Right DAC Switch’ on
amixer cset name=‘Left Headphone Mixer Left DAC Switch’ on
amixer cset name=‘DAC Playback Volume’ 999,999
amixer cset name=‘Headphone Mixer Volume’ 999,999

but it gives me “amixer: Cannot find the given element from control default”

"One more thing since it’s a new machine; check for available bios updates. "
only drivers for windows

maybe downgrade the kernel?

Data from a VM in another distribution with an emulated AC97 audio codec is not much help here

Package sof-firmware is included on all official ISOs since at least January 2022
Manjaro 21.2.2 released
And data in post #3 shows driver sof-audio-pci-intel-apl in use

Package alsa-ucm-conf was created as a separate package from alsa-lib to provide the Use Case Manager profiles and should be included on any Manjaro ISO

Package pulseaudio-alsa provides the ALSA configuration to set PulseAudio as default sound server and create virtual controls. This package is common to all Arch distributions and no additional asound.conf or .asoundrc configuration should be needed

ALSA data confirms that both PulseAudio and PipeWire appear to be running, But PipeWire is only partially installed and only capable of creating conflict problems for PulseAudio
PipeWire is not a required dependency like other DEs so Xfce users can uninstall pipewire and alsa-mixer-paths to use PulseAudio without conflict
But dealing with conflicting software servers will not help resolve hardware or driver issues in ALSA

ALSA data shows only HDMI devices detected for audio playback, no device detected for analog audio to speakers or headphones

amixer: Cannot find the given element from control default

The amixer commands are failing for 2 reasons:

  • no card number specified so amixer commands can only find default PulseAudio controls - usually 2 virtual audio controls for PulseAudio or PipeWire - Master for audio playback and Capture for audio capture
    (amixer would usually show the default controls but they may not be present following changes to asound.conf)

  • even if the card number had been included, the commands would not work because the audio controls for Headphones, Speakers, DAC are not present in previous alsa-info data
    and nothing since is likely to have made those controls appear

Please post response to this command to show all available audio controls for onboard audio device

amixer --card=0

Checking Manufacturer for BIOS updates is a good idea at this time

maybe downgrade the kernel?

I suggest you update to the latest kernel version and hope it has a patch for the audio codec on this system

sudo mhwd-kernel -i linux519

If audio is still not working as expected, get ALSA information again to see if anything has changed

sudo alsa-info.sh --upload
1 Like


i’m hopeless ahaha

[victorevans@victorevans ~]$ amixer --card=0

Simple mixer control ‘Mic’,0

Capabilities: cvolume cvolume-joined cswitch cswitch-joined

Capture channels: Mono

Limits: Capture 0 - 4096

Mono: Capture 2816 [69%] [11.00dB] [on]

guys!!! could you explain that to me, like, in command line, a step-by-step to do this??

Passo 1: Se tiver recém-formatado, dê um apt update e depois um upgrade pra atualizar tudo direitin e evitar erros

Passo 2: Clone com o git esse repositório .

Passo 3: Instale o .deb da pasta raiz (firmware-sof-signed_1.7-1_all.deb)

Passo 4: Após isso, vá na pasta kernel e instale cada um dos .deb lá

Passo 5: Volte, e agora vá na pasta tplg e copie todos os arquivos de lá para a pasta raiz (custom-kernel)

Passo 6: Entre como administrador com o sudo su, dê permissão para executar no arquivo make.sh com o chmod +x , e então execute-o ./make.sh

Passo 7: Após o processo ter terminado, reinicie o seu PC, e provavelmente o áudio estará funcionando.

it is the same notebook i have.
please, save me. it is the solution. but idk how to do this steps

you all could see this link and see the exact model.

i’m thinking to swtich to linux mint xfce in order to do this

apparently i need to install this kernel custom-kernel/README.md at main · yangxiaohua2009/custom-kernel · GitHub

but, I could try on manjaro xfce first, if you tell me how, i’m really a noob…

update: my bluetooth headphones works via bluetooth

New ALSA data in previous post is better than before. ALSA is now able to detect the onboard audio codec as playback and capture device

card 1: sofessx8336 [sof-essx8336], device 0: ES8336 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

amixer --card=0 in post #21 is showing ALSA Mic control for USB webcam

ALSA mixer controls for onboard audio card 1 show Headphone and Speaker controls are both muted

Simple mixer control 'Headphone',0

  Front Left: Playback 3 [100%] [0.00dB] [off]
  Front Right: Playback 3 [100%] [0.00dB] [off]
Simple mixer control 'Speaker',0

  Mono: Playback [off]

use this command to unmute both controls

 amixer -c1 sset Headphone unmute; amixer -c1 sset Speaker unmute

I did a new upload.

amixer -c1 sset Headphone unmute; amixer -c1 sset Speaker unmute
amixer: Unable to find simple control ‘Headphone’,0

amixer: Unable to find simple control ‘Speaker’,0

Latest ALSA data shows onboard audio now detected as card 0 and USB webcam as card 1

**** List of PLAYBACK Hardware Devices ****
card 0: sofessx8336 [sof-essx8336], device 0: ES8336 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 5: HDMI 1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 6: HDMI 2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofessx8336 [sof-essx8336], device 7: HDMI 3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Use this command with card name rather than number to unmute Headphone and Speaker

 amixer -c sofessx8336 sset Headphone unmute; amixer -c sofessx8336 sset Speaker unmute

still no sound. ok, I think i’ll switch to mint and try that solution anyway…

1 Like