XFCE Gnome Polkit Agent Doesn't Default to Current User Logged On

I don’t know if this is a bug, but it is behavior that I am not accustomed to from using Gnome, KDE, etc.

The xfce-polkit-gnome-authentication-agent-1 shows a drop down if there are multiple users on the system, but doesn’t default to the currently logged on user. The Gnome and KDE polkit agents do this by default. It is really annoying to me, because I use a Yubikey to do password-less admin prompts if I have the key plugged in. The default XFCE agent wouldn’t work properly - seemingly due to the drop down needing to be clicked.

I wound up installing polkit-kde-agent and enabling that service and disabling XFCE’s service for it (both located in /etc/xdg/autostart). I changed these values so that XFCE’s wouldn’t start and KDE’s would.

polkit-kde-authentication-agent-1.desktop: OnlyShowIn=KDE;XFCE;
xfce-polkit-gnome-authentication-agent-1.desktop: NotShowIn=XFCE;

Either way, does anybody know if there is a setting I can change in the XFCE polkit agent to auto-select my user account when I’m running an admin tool?