XFCE Desktop user wallpaper not showing at login page

Here are the steps to reproduce:

  1. Us an image from you home directory and add as background.
  2. In lightdm select “use user wallpaper if available”.
  3. Log out.

You will see that it won’t show the chosen wallpaper at the login screen. Only works with the wallpapers that com from the usr/share/backgrounds

Any idea what’s the issue?

Had the same
I just copied my wallepapers in /usr/share/backgrouds/ and select in lightdm

1 Like

Hm interesting…I reported it here too Possible bug with the custom wallpaper selection (#161) · Issues · Xfce / xfdesktop · GitLab and I wonder if this is a Manjaro issue or an XFCE issue.

I had this in Lxqt

user wallpaper at the login screen?

That may work if the wallpaper is located in /usr/share/ but not with a wallpaper located in /home/$USER because the user folder on Manjaro is only accessible to the user.

Just a thought - how can the display manager read files in the users home when the display manager has no permissions on the user’s home?

If you use the slick greeter it is possible if there is no background defined in the greeter conf. I am not sure how this is done but apparently the user’s dconf settings is available using the dbus.

I have seen this in other distributions using Xfce, lightdm cannot access user home folders

I made a folder for custom user backgrounds in system folder

sudo mkdir /usr/share/backgrounds/$USER/

It can if other users have read permission – but that means your home directory isn’t really private.
Otherwise, it is indeed recommended to put it elsewhere:

It is recommended to place the PNG or JPG file in /usr/share/pixmaps since the LightDM user needs read access to the wallpaper file.

Ok so this is a permission thing then. Nothing to really fix, right? Unless you use the backgrounds directory path and add your backgrounds there.