XFCE Desktop Icons and Workspace 2 Wallpaper Missing After Every Reboot

I think this bug was introduced with the last update (or perhaps since then). I can restore my desktop icons via Desktop Settings >> Icons tab and then selecting a new "Icons Orientation."The icons and the Workspace 2 wallpaper are restored and then I can then select the original or any other desired Icons Orientation.

Sadly, it all goes “poof” again after the next reboot and must be manually restored after reboot.

$ inxi -Fxxxrza
  Kernel: 6.3.9-1-MANJARO-ARM arch: aarch64 bits: 64 compiler: gcc v: 12.1.0
    clocksource: arch_sys_counter parameters: initrd=/initramfs-linux.img
    root=/dev/mmcblk2p2 rw rootwait audit=0 splash
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro ARM base: Arch Linux
  Type: ARM System: Pine64 Pinebook Pro details: N/A serial: <filter>
  ID-1: cw2015-battery charge: 96% condition: N/A volts: 4.1 min: N/A
    model: N/A type: Li-ion serial: N/A status: charging
  Info: model: N/A variant-1: cortex-a53 variant-2: cortex-a72 bits: 64
    type: MST AMCP arch: ARMv8 family: 8 model-id: 0 stepping: 4
  Topology: cpus: 1x cores: 4 mt: 2 tpc: 2 st: 2 threads: 6
    smt: <unsupported> cache: N/A
  Speed (MHz): avg: 608 high: 1008 min/max: 408/1416:1800 scaling:
    driver: cpufreq-dt governor: schedutil cores: 1: 408 2: 408 3: 408 4: 408
    5: 1008 6: 1008 bogomips: N/A
  Features: Use -f option to see features
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1 mitigation: __user pointer sanitization
  Type: spectre_v2 mitigation: Branch predictor hardening, BHB
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: display-subsystem driver: rockchip_drm v: N/A bus-ID: N/A
    chip-ID: rockchip:display-subsystem class-ID: display-subsystem
  Device-2: rk3399-mali driver: panfrost v: kernel bus-ID: N/A
    chip-ID: rockchip:ff9a0000 class-ID: gpu
  Device-3: Microdia HP Integrated Webcam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1.2:3
    chip-ID: 0c45:6321 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev dri: rockchip
    gpu: cdn-dp,dw-mipi-dsi-rockchip,dwhdmi-rockchip,innohdmi-rockchip,rockchip-dp,rockchip-drm,rockchip-lvds,rockchip-vop,rockchip-vop2
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1536x864 s-dpi: 96 s-size: 406x229mm (15.98x9.02")
    s-diag: 466mm (18.35")
  Monitor-1: eDP-1 res: 1536x864 hz: 60 size: N/A modes: 1920x1080
  API: OpenGL v: 3.1 Mesa 23.0.4 renderer: Mali-T860 (Panfrost)
    direct-render: Yes
  Device-1: simple-audio-card driver: asoc_simple_card bus-ID: N/A
    chip-ID: simple-audio-card:es8316-sound class-ID: es8316-sound
  Device-2: simple-audio-card driver: N/A bus-ID: N/A
    chip-ID: simple-audio-card:hdmi-sound class-ID: hdmi-sound
  API: ALSA v: k6.3.9-1-MANJARO-ARM status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Message: No ARM data found for this feature.
  IF-ID-1: wlan0 state: up mac: <filter>
  Device-1: rk3399-uart driver: dw_apb_uart bus-ID: N/A
    chip-ID: rockchip:ff180000 class-ID: serial
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.0
    lmp-v: 9 status: discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 1.02 TiB used: 16.51 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk1 maj-min: 179:96 vendor: SanDisk model: SD64G
    size: 59.45 GiB block-size: physical: 512 B logical: 512 B tech: SSD
    serial: <filter> scheme: MBR
  ID-2: /dev/mmcblk2 maj-min: 179:0 vendor: SanDisk model: DA4064
    size: 58.24 GiB block-size: physical: 512 B logical: 512 B tech: SSD
    serial: <filter> fw-rev: 0x8 scheme: GPT
  ID-3: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 211210WD temp: 28.9 C scheme: GPT
  ID-1: / raw-size: 57.77 GiB size: 56.79 GiB (98.31%) used: 16.46 GiB (29.0%)
    fs: ext4 dev: /dev/mmcblk2p2 maj-min: 179:2
  ID-2: /boot raw-size: 487 MiB size: 486.7 MiB (99.94%)
    used: 48.2 MiB (9.9%) fs: vfat dev: /dev/mmcblk2p1 maj-min: 179:1
  Kernel: swappiness: 60 (default) cache-pressure: 80 (default 100) zswap: no
  ID-1: swap-1 type: zram size: 5.67 GiB used: 0 KiB (0.0%) priority: 100
    comp: lzo-rle avail: lzo,lz4,lz4hc,842,zstd max-streams: 6 dev: /dev/zram0
  System Temperatures: cpu: 35.6 C mobo: N/A
  Fan Speeds (rpm): N/A
  Packages: pm: pacman pkgs: 915 libs: 225 tools: pamac pm: rpm pkgs: 0
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://repo.ialab.dsu.edu/manjaro/arm-stable/$repo/$arch
    2: https://nocix.mm.fcix.net/manjaro/arm-stable/$repo/$arch
    3: https://mirror.math.princeton.edu/pub/manjaro/arm-stable/$repo/$arch
    4: https://manjaro.kyberorg.fi/arm-stable/$repo/$arch
    5: https://ftp.gwdg.de/pub/linux/manjaro/arm-stable/$repo/$arch
    6: https://mirror.alpix.eu/manjaro/arm-stable/$repo/$arch
    7: https://manjaro.ynh.ovh/arm-stable/$repo/$arch
    8: https://southfront.mm.fcix.net/manjaro/arm-stable/$repo/$arch
  Processes: 201 Uptime: 12m Memory: total: N/A available: 3.78 GiB
  used: 807.6 MiB (20.9%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.29

Thanks for any solutions or ideas!



Restore your icons and wallpaper
rm -R ~/.cache/sessions/*
logout and back into your desktop session

That fixed it. Thanks so much, Darksky!

Since I posted here something else strange occurred. My NumLock stuck on and I could not turn it off. I went to Setting >> Keyboard and tried checking “Restore num lock state on startup” and rebooted but that didn’t help. Then I tried unchecking it and rebooting and that didn’t help either.

Next I opened Settings >> Keyboard again and also a terminal F6 (which didn’t have the stuck numlock, hampering my efforts) to try using or assigning the numlockx command (whatever it does) and I somehow managed to get the persistent numlock to turn off in the desktop session.

Do you have a suggestion for fixing a stuck numlock too?

Again, thanks for your support. It is most appreciated!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.