Xfce and command line no GUI uses two differen kyboard mappings

Hello, I have just got a new system and made a fresh standard installation.
I am using 104 keyboard mapping in Italian.
In the XFCE terminal everything is fine, but if I switch to command line login with Alt+F6 for instance, when I am logged in I see some keys are different.
This key in particular:

image

In command line bash after login, it is ‘/’ instead of ‘-’
Any clue why is this happening?

First, list all acceptable values with the command localectl list-keymaps and then add this in /etc/vconsole.conf as root. See releated wikipage for more information:

KEYMAP=us #AFAIK for italian it is "it"

Hi @mgazzin,

I think your locale is screwy. Please see:

https://wiki.manjaro.org/index.php/Locale

You’ll have to make sure your global setting and your user’s setting is the same. That means language and keyboard layout.

To me it quickly looks/sounds like your user’s is fine, you just need to set the global one. To confirm, run:

localectl list-locales

And

sudo localectl list-locales

Provide the output if you wish us to have a look.

Thanks @ishaanbhimwal and @Mirdarthos !
I forgot to mention that this was happenning just after I disabled GUI with:

systemctl stop lightdm
systemctl disable lightdm

Now if I connect with SSH it is all right:

image

and the keyboard seems to work well.
Thank you!