X96 Air - USB boot stopped working

I was pleasantly surprised to discover that my X96 Air Q1000 can boot Manjaro directly off a USB 3 SSD, or at least it could. I can still boot Manjaro off SD card but yesterday I tried to boot CoreELEC-Amlogic-ng.arm-19.1-Matrix-Generic.img off an SD card. It failed to boot and I don’t see how trying to boot CoreELEC could’ve stopped USB boot working but it was after trying to boot CoreELEC that USB boot stopped working.

I can still access my USB SSD both under Android and Manjaro when booted off SD card so the port seems to be working, I just cannot boot off it any more because it says ‘device not found’ whether I use the partition UUID or /dev/sda2 in extlinux.conf. Manjaro starts to boot but only gets to the mounting /root bit.

I have ruled out it being the disk (I have tried 3 SSDs which I have checked are fine with SMART and badblocks) being faulty, I have tried different SATA enclosures, I have reflashed the stock Android rom twice and I have factory reset Android so I’m out of ideas now.

If no-one has any suggestions I should be able to work around this by just having the boot partition on microSD card then root on SSD but its more convenient being able to boot directly from USB.

1 Like

Very odd!

I’ve been using this same SSD and SATA adapter for weeks with my X96 Air and it has worked without having to use:


As a kernel argument (in extlinux.conf) but as of yesterday it seems it needs it!?

I bought 2 of these adapters because I didn’t think that was required! Oh well! :smile:

I would say that is not a problem of firmware etc…
I have trouble too after CE-boot from SD. I use several USB3 sticks and USB3-SSD . Currently I use portable SSD without problems.

It seems that the extlinux.conf files is changed after first sucess boot:
APPEND root=LABEL=ROOT_MNJRO rootflags=data=writeback rw …
is replaced:
APPEND root=PARTUUID=3ffa9b30-02 rootflags=data=writeback rw …

Simply replace current extlinux.conf on the manjaro boot with the original without the PARTUUID and everything is fine again.

Use the toothstick method once again.

Hope it will help.

under Android install
‘Reboot to Libreelec for Android TV’
to Boot from SD or USB