X11 log: "Failed to start NVIDIA kernel module"

System hangs when starting KDE X11 from TTY2 Had issues with NVIDIA drivers that were resolved here; laptop worked fine afterwards for a few hours, even across reboots. Eventually, the laptop runs out of battery and shuts down, and I am back to the black screen after rebooting. Xorg.0.log looks normal, then gives the error in the title a few times before a fatal server error: “no screens found” occurs and X fails to boot. Nothing should’ve changed, as far as I can tell (though I don’t know that for sure, as I was installing CUDA related stuff before the shutdown and hadn’t rebooted since).

can you login to console with Ctrl-Alt-F3 ? a sudden shutdown caused by powerloss can crash anything.

Yes; I was able to access TTY2 and could check the X log from there.

is the problem still existing that you can only boot to console ?
what happened ? your laptop shut down suddenly because the battery was down ?

Presumably, yes. I’m able to boot to console without bootmode 3, but TTY1 is a black screen. Going back to it shows a blinking cursor in the top left and nothing else.

man this is a total confusing answer. from what i understand is that you can switch with Ctrl-Alt_Fxx key but you can not login with username and switching back shows just a blinking cursor ? is this correct ?

I can login with username and have full functionality in TTY2 (or other TTYs), including logging in. TTY1 is just a black screen (with the blinking cursor in the top left corner when I tab in again) and is unresponsive.

so login to TTY2 and check

envycontrol -q

please report


cat /var/log/Xorg.0.log | grep nvidia

errors reported in this log ?

envycontrol -q reports “nvidia”.

Xorg log reports a few things, mainly “no monitor specified for screen ‘nvidia’”, which reads like it’s the main error. I can’t copy the full logs over in my current situation.

are you using an external monitor ?

I am not; this is a laptop with one attached monitor.

a shot in the dark baut try this one:
boot to console, run envycontrol and shutdown-command

sudo envycontrol -s hybrid
sudo shutdown -h now

after shutdown start the laptop again. bzw. did you any updates or installations after we configured the card ?

Not to my knowledge, no. Trying this now.

Nooooooo , i should have read this before. Sorry but this is a typical failure that happened. you installed “someting” that you should have investigated before. What was it ? The newest, hardest Shice ?
These CUDA-Variants do differ a lot and they will break ! your system if the wrong one is installed.
Is there ANY reason that you needed it and what was needed or just playing around ?

X log says “Failed to create screen resources(EE)”; specifically, “modeset(G0): Failed to create pixmap”.

afaik I just installed CUDA directly from pacman. It is required for my use case.

that’s no excuse, “just installed from pacman”. sorry but why ?
This CUDA-installation did changes to your configurations and none of us can tell you what.

boot into console and run

sudo rm /etc/X11/mhwd.d/nvidia.conf

reboot and pray

i’m out

In case of such uncertainty I’d rather move it to a different name and/or location first, so it could be easily restored.


sudo rm /etc/X11/mhwd.d/nvidia.conf


sudo mv /etc/X11/mhwd.d/nvidia.conf /etc/X11/mhwd.d/nvidia.conf.backup

for instance

After this, I fresh installed, as I wasn’t sure how I’d go about fixing my setup anyways. For the time being, I’m using Wayland with Intel and installed CUDA from the runfile instead; I may revisit NVIDIA drivers for display later, but for now, I’m not going to worry about that, as this computer is relatively important to me and I don’t want to setup Linux for the third time.

What happened: The CUDA AUR from pacman messed with my display drivers. I have no idea how, I have no idea why. Do not do that. CUDA is working fine and both Wayland and X are working fine for me. Considering this solved.

I don’t know why you would install CUDA from the run file or from AUR when there is the one in the manjaro repository. By doing that you’re just setting yourself up for more work and trouble then necessary.