X1 Nano fingerprint gui issues on kde "No devices found!"

As said above, i installed version 1.09 of fingerprint gui off the AUR and when I start it up it says it doesn’t detect the fingerprint sensor. When I put lusb into konsole I get this

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 13d3:5411 IMC Networks Integrated Camera
Bus 003 Device 002: ID 06cb:00bd Synaptics, Inc. Prometheus MIS Touch Fingerprint Reader
Bus 003 Device 004: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Look at device 002 I looked into it and fprint does say it’s one of the fingerprint readers supported however fingerprint gui doesn’t seem to detect this.

Am I not doing something right with fingerprint gui?

have you had a chance to check the Arch wiki setup guide? looks like there are a few post install setup tasks.

Ah sorry I didn’t and am supposed to delete this file: polkit-kde-authentication-agent-1.desktop
I found it following the instructions for files but um, don’t know how to delete it, it just desribes needing an authentication agent if using a window manager but I don’t know what that means or if it’s even related to this issue.

Ok first step is follow the instructions you get when you run the install.
You can rebuild it and they might trigger again.

Then you will look for the files you need to delete. In Linux you use the rm command, you can get more info on it by typing man rm be careful with it, it will delete whatever you tell it to delete.

If you have one of the standard DE’s like Gnome, KDE etc you don’t need a custom authentication agent.
We can worry about that later. Just start with running the build again to get your instructions, delete the file and run the diag command it suggests. It also suggest doing a reboot after the install to ensure permissions are ok.

Okay I went through the instructions and deleted the file I was told but am getting the same issue, I looked through the directions on the website for fingerprint gui but nothing mentioned if I wasn’t getting any detected fingerprint reader.

I installed th fingerprint gui from the aur add/remove software part of kde, is this the wrong way to install it or something?

hello. i think i have the same issue as you. have you found a solution yet? please share if so

1 Like