X-Pen Customization software


i’ve recently aquired a X-Pen tablet which runs no problem out of the box in Manjaro somehow even prior to downloading or installing the driver.

i would guess the software necessary for customizing the tablets keys come packaged within the driver download?
but then again, i have no clue as to what to do with the type of file contained in the driver download folder to have access to the software…

thanks for any help with this issue!


You mean XP-Pen … and you downloaded a *.tar.gz file from their site, right? Might depend on the tablet model tho. Extract the content of that archive, enter in that folder and open Terminal in that folder. Then you run:
sudo ./install.sh

I think you might have to then run:
sudo chown $(whoami) /usr/lib/pentablet
and ten
sudo chmod +x /usr/lib/pentablet/pentablet

Reconnect your tablet, or reboot the system and you will have the app working and the UI to configure the express keys and map/callibrate it.

Edit: There is an AUR package for it AUR (en) - xp-pen-tablet
You run from terminal:
pamac build xp-pen-tablet
type y for yes and press Enter to continue, and you should be good to go after that.


I’m new in the forum and I don’t know if this is the correct why to address a question (replying to an ongoing topic), sorry for that, but since the problems seems to be the same…

I have acquired a xp-pen star06c and I’m having problem using it in Manjaro. I have tested in a W10 machine and it worked properly.
I’ve installed the xp-pen-tablet form AUR, done chown and chmod as you pointed, and the UI exhibits the massage “please connect device”.
It is listed in xinput, however I’ve no idea why it is listed as:
XP-PEN star06c id=19 [slave pointer (2)]
XP-PEN star06c Mouse id=21 [slave pointer (2)]

and also

XP-PEN star06c Keyboard id=18 [slave keyboard (3)]
XP-PEN star06c id=20 [slave keyboard (3)]

It appears in usb list:
Bus 001 Device 009: ID 28bd:0062 XP-Pen star06c

but it is not responding to writing or even moving the pen, nothing.

thank you all


I presume you have restarted your linux system after installing the drivers. Have you tried disconnecting and connecting back the tablet?
From your profile it seems you are on i3wm … really don’t know how is dealing/responding to stylus input events, or if needs a specific i3wm command in the i3config. According to this comment, all should work and probably is you that made that comment :slight_smile:


It seems to me that the problem is with this specific tablet (xp-pen star06c), and others that does not have linux drivers provided by xp-pen. Different models, from xp-pen, that have linux driver support work properly with the xp-pen-tablet package.
Long story short, I’m using Digimend driver. After uclogic-prob BUS-NUM DEV-ADDR, it is working properly. Only thing is the buttons (it has 6 buttons and a scroll) are not assigned, only the scroll. However I think it can be done by XF86.

1 Like

Marvelous, worked a charm for me.


3 posts were split to a new topic: XP-Pen star03 drivers and configuration