Wrong Password bug

Well, hello there. I have a Linux Manjaro device here that I don’t use too often, thus I update it rarely (once or twice a year). This time Network Manager decided to give me the famous wrong password bug, basically saying no password is correct. I have it connected to my mobile network from back in the day, but now that I have a home wifi I want to connect it there.

Here’s the thing. I am more than sure it is either the kernel being outdated or “[device] wifi.scan-rand-mac-address=no”, but the tutorial I found for kernel updating was very technical and thus, obviously, not an option and the second line changing thing did not work because there is no “networkmanager.conf” anywhere on my PC, not that the search could find. I did not find anywhere if I actually needed to create this file myself, but it doesn’t, at least, seem to be a solution.

Oh, and one last thing, my Win 7 has been outdated for more than a decade and I’ve never encountered any really big problems with it, why does my Manjaro device keep breaking? It’s the fourth time I had to search for software update related bugs. Am I doing something wrong? Do I update my system somehow incorrectly? Do I not see an obvious “Fix all” button? I just don’t think encountering a bug every time I update the system to be a normal thing. …the first time it happened I had my pacman stop working for being too outdated lol

I’ll try to put screenshots in the comments cause I apparently can’t upload pictures there. Interesting and weird, I know.

Also no, I can’t connect the Ethernet cable because the thing doesn’t have a nest for it. It also doesn’t have CD tray which is offensive, I know. Oh well.

If someone can help, I thank you in advance. Also, please explain what to do as simple as possible, I don’t speak coding at all

…that is exactly your problem. When using a rolling release and not updating, it will break.
If you dont use this device often, Install mint or debian.

1 Like

I have seen problems here with more modern Wifi routers because of their use of WPA3 by default - or some mixed mode including WPA3.
Try configuring your router to use the still secure WPA2 security instead.

But I’m not sure how you can do that if you cannot connect to your router in the first place to change this configuration setting. :man_shrugging:
… use a phone or a different computer …

Do not use just any guide - prefer the Arch wiki and/or the Manjaro wiki.
and pay attention to detail:
the file name is

not all lowercase like you wrote
it is located in the
/etc directory - in a directory named

the full path to it:

Alright, first, I did not know lowercase mattered. Guess I’m too much of a windows user :stuck_out_tongue:
However, I manually checked the /etc folder (both of them) and neither have NetworkManager or anything connected with it. I’d send pictures but I can’t for some reason, all you can do is trust my words :c

As for the router, I don’t know how to configure it. I have it connected to my main PC, so I can see the config, but there’s no WPA3 or WPA2 anywhere. I may call a technician if it’s something an unexperienced user can’t understand

If you have an android phone - connect your pc with the android using your charger cable.

Then enable your phone’s hotspot using USB - your Manjaro system should pick up the connection and you can update your system.

1 Like

if you have Network Manager (and you do, you said so yourself and it is also the default in any Manjaro flavour)
then you definitely do have a directory called NetworkManager in /etc

I do not know what you mean when you say

checked the /etc folder (both of them)

because: there is only one - not two

as for the router configuration (WPA2 …)
it was only my guess that this would help your issue

It has to be a pretty special router if this kind of thing is not configurable.
You just do not know where to look - perhaps the option is named unintuitively.
No idea without access to the manual.

1 Like

I think I finally realized what was going on. Ignore my previous claim about have several etc folders (I have 3 of them, in fact, but they are just drivers for Windows, for Wine that is). I changed the NetworkManager.conf but it resulted in no difference. Is there some other way to update it without reinstalling the OS again?
As for the router I use TP-LINK, one of the most common out there

I did update the system (although my phone can’t see the PC and wise versa - Androids hate Linuxes and don’t know a single way to change that, Bluetooth still doesn’t work though), and the update was successful. I still can’t connect to my main wifi regardless, only to my phone.
I used “sudo pacman -Syu” though, I think there are other commands like “sudo pacman -Suu” or something, but I never knew the difference

What did you change - and what was that change supposed to achieve?

You need some kind of systematic approach - and if you want help here, you need to tell us what exactly you did, what errors you got and so on.
We do not sit in front of your device - you do.

re the Android phone for networking:

You connect it via USB cable and enable tethering on the phone - so you can use it’s internet connection.
You can even connect it wirelessly to your router - so that you do not use up possibly expensive mobile data.

That way you also know whether your router actually works - when the phone can connect to it.

to see what is going on while you are trying to connect (and fail to do so)
you can have a live view of the system log running in a terminal

first way:
journalctl -f

second way:
sudo dmesg -W

it is quite easy to figure that out

read the wiki
the Arch wiki as well as Manjaro’s

and the manual pages for the programs
man pacman
man pamac

Alright, let’s do it slowly. First I went to that NetworkManager folder in the /etc and in NetworkManager.conf I simply added


Then I reloaded the PC (obviously saved the changes) and found nothing has changed.
journalctl revealed this https:// cdn.discordapp. com/attachments/800394176687505439/1040322218367918150/20221111_004820.jpg and it keeps going. I probably should remind everyone who listens (and god thank you all for that) that I did update the entire system using mobile data prior to making the post, it just seems like the Network Manager itself didn’t get updated or something

There is a typo at least, it’s missing a c: wifi.scan-rand-mac-address=no.
edit: I looked at your journal excerpt above. There is nothing much related (wpa_supplicant journals a REGDOM event for your wifi-interface wlo0, but I don’t think this is a cause for the error).
Perhaps the last journal specifically for wifi reveals more:

# journalctl -b --unit={NetworkManager,wpa_supplicant}

Pay attention to detail!
You have a typo there!

It should be:


I also had problems with the default behaviour of changing MAC addresses for scanning
so I also added this:


try it if you like - it may help

That’s my typo. The keyboard I have here is a bit old… being about 20 years old in fact.
I finally found a clue when I tried to connect to my main wifi and it was saying something about the beacon loss. Phone decided to start working through USB without problems or extra apps again, which compliments my theory that all code is just a constantly evolving hivemind without any sort of rules or limits; but I could transfer actual screenshots this time. Look.


It says something about wrong password, but it really is not the case, I compared them two several times
Also, I’m going afk for several days, please don’t close the thread until it’s fixed. Really don’t wanna reinstall the OS

My typo. Sorry. This keyboard I use here is quite old. I’ll try the [connection] thing now but as I’ve stated above, I’m going afk for several days and will not reply tomorrow, sorry again.
I’ve also included screenshots in my other reply. Thanks for everything

“Beacon loss” is often happening when the kernel module for the wifi has powersave features enabled. To disable, you look for configuration settings with modinfo yourwificardmodule. The relevant module you’ll find in dmesg |grep wlo1 or with lspci -k.

Don’t worry about it being wrong then. The networkmanager alert may appear erroneously when authentication fails for other reasons (that’s why the others above asked about WPA2/3). To be certain, delete the connection in NetworkManager and add it from fresh.

Since you now have internet on the machine with either the phone or your other wifi, post regular output next (screenshot excerpts are semi-helpful, too easy to miss something).

It is a pity that you only included screenshots
when copy pasting the text was likely just as easy

screenshots are discouraged because of this, especially when it’s text output:
they cannot be parsed - and I cannot copy/paste a relevant section to show you what stood out to me

descriptive then …

we saw that the handshake failed when the password was supposed to be validated

since it worked before, but now not anymore
it could have to do with the kernel that you are currently running

Try using a different kernel.

Install an additional one if you only have one - so you have the ability to choose between what may work and what may not.

1 Like

I’m finally back, took a while longer than expected. Alright, I’m willing to update the kernel or use a different one, but so far I couldn’t find any download links to them.
Seems like it’s something you don’t just install and instead fix through heavy consoling. I really don’t like to touch that stuff much, I tend to break stuff that shouldn’t be breakable. But I’ll try it anyway, I’ll mark a reply with a solution

Nope, it’s not kernels and my computer is now definitely updated completely and fully. And it still does not connect to wifi, same problem remains

I think I should explain it better. It worked before, sure, but it worked shortly (about a few months) after I installed the entire OS for the second time. That’s when I connected my phone’s wifi to the PC. A year later and several postponed updates later I got wifi at my place, and only that is when I noticed the wifi not connecting. But if pacman can’t fix it via updates, and kernel is not it, then what could it be?