Wrong fonts and icons missing after Manjaro KDE update to 5.27

It happened about two months ago with the first 5.27 Manjaro update. I’ve been busy with work and had GNOME as well so just switched to GNOME and in the meantime, I’ve tried different solutions I could find on forums. I think I’ve tried every trick I could find with no luck. I’ve tried different GPU drivers, both NVIDIA free and proprietary as well as using only the Intel i915 driver. I’ve removed kde cache directory. I’ve changed themes a few times and even downgraded libscreen to 5.26 but I still same issue. I’ve recovered a few icons but still, size of both icons and fonts is not right, especially in Settings and Konsole terminal. Currently, I’m at 5.27.6 hoping it’s a bug and been fixed.
Some screenshots

One thing you could try with regard to the icons is… :arrow_down:

kbuildsycoca5 --noincremental

… but I don’t think this would help on account of the missing fonts.

Some font packages were consolidated, resulting into other font packages having been dropped from the repo due to redundancy. Perhaps you could look at the font packages in the repo — or possibly the AUR — in order to find the fonts that you like.

But by the way, we’re on Plasma 5.27.7 now.

You should update your system before attempting to install anything else.

Hi, sorry yes I’m on the latest, did the update this morning but still nothing. I’ve tried kbuildsycoca5 but still icons are missing as on the picture. Unless someone has some idea I think I’ll try a last resort, remove the whole KDE as I still have GNOME and try to reinstall the minimal version. It doesn’t have many extra settings so may be worth giving it a go.


What is the icon theme you are trying to use?

If you dont mind losing settings, then you can do a refresh of plasma:

cd ~/.config && for j in plasma*; do mv -- "$j" "${j%}.bak"; done && rm ~/.config/Trolltech.conf 
cd ~ && kbuildsycoca5 --noincremental
1 Like

I’ve tried to run your commands, still the same thing. I’ve been using standard themes Breath or Breeze. I’ve tried them all but each one has fonts and icons issues. I have some plasmashell and systemsettings warnings in the journal log but they have always been there so I don’t think they are related.

If it was there’d be a lot more posts about it.

Most often problems like this are caused by something in your KDE configuration. Easy way to test that is create a new user and see if the problem is there when logged in on that user.

1 Like

I also have a post on the KDE forum, and they recommended the same thing and I can confirm that the new user works fine, my question is why cleaning up the cache and config didn’t do the trick for my existing user.

It must be something that is outside the scope of the usual process.
(which specifically targeted files named *plasma* in the ~/.config directory)
Something like ~/.icons or ~/.fonts or similar.

Probably ~/.cache/icon-cache.kcache and ~/.cache/fontconfig/*.

I recommend deleting those from a tty while completely logged out of Plasma.

I finally get it working again. Thanks for all the help. Unfortunately, I don’t know if all 3 are required or which one did the trick, as I’ve done all three before testing again. With Gnome and KDE i had deps issue manjaro-kde-settings package conflicting with manjaro-gnome-settings, somewhere in the forum, I’ve read it’s only used for init settings and I had to remove one. So I’ve removed KDE months ago. It does affect .xinitrc file, however, I had the same issues in Wayland so hard to say don’t know what Wayland is using to init and it’s been working fine for months and many updates in between, so I don’t think that’s the issue, today I’ve removed GNOME completely, installed the KDE settings package and also removed icon and font cache files.

~/.cache/icon-cache.kcache and ~/.cache/fontconfig/*

and I’ve got my desktop back. Hard to say if cache helped as I already did remove cache once before with no luck and again I happily run both GNOME and KDE for months before the issue started. I think something introduced with an update to GNOME or KDE a few weeks back broke things.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.