Wrong file association

Hi there! I have a problem with file association. Let me show a problem

VLC player has association with a lot of files, what is not related to VLC. It happened after VLC version updating. Does anyone know how to fix it globally to avoid manually changing each of type association?

Remove VLC from that list for any php file, just one, apply and you are good to go.

FWIW this also happened to me recently on XFCE. That is; it’s not KDE specific.

well, It’s related not only for PHP file. There are a lot of files what’s associated with VLC, but this associations are wrong

Looks like you are right. But what it can be? Seems we need to somehow to reset associations by default

No doubt are wrong files associations. I have 3 native installs, two on unstable and one on testing. Could not reproduce. Tested on VM install and no trace of such wrong file association either. Are those global, aka system wide or just in your user home? You can test with a TMP user.

I’ve created a tmp user and file associations look ok for a tmp user. Seems, my current user has a wrong file association. But, how I can reset by default?

As your normal user

cp /etc/skel/.config/mimeapps.list ~/.config/

resets user mime settings to fully vanilla – but if I’m not mistaken (it was for me in a flurry of installs/tweaks just after installing Manjaro for the first time and I don’t in fact remember what I did) that did not fully work for me. Logging out and back in after doing that can in case supposedly not hurt. Of course first backup your existing ~/.config/mimeapps.list if you want to be able to restore.

First just look in ~/.config/mimeapps.list I suppose…

1 Like


On my relatively clean KDE:

> ls -la /etc/skel/.config
total 4
drwxr-xr-x 1 root root   64 Aug 16 15:20 .
drwxr-xr-x 1 root root  160 Dec  1 09:05 ..
drwxr-xr-x 1 root root   42 Aug 16 15:20 autostart
drwxr-xr-x 1 root root   16 Aug 16 15:20 falkon
drwxr-xr-x 1 root root  114 Aug 16 15:20 gtk-3.0
-rw-r--r-- 1 root root 3413 Jan 30  2022 kdeglobals


As a reference, this is the contents of my ~/.config/mimeapps.list:

[Added Associations]

[Default Applications]

Which shows some dupes that i just now noticed because of this thread :rofl:

I see. Who’d have thought that was XFCE-specific…

rene@p55m:~$ pacman -Qo /etc/skel/.config/mimeapps.list 
/etc/skel/.config/mimeapps.list is owned by manjaro-xfce-settings 20220616-2

[EDIT] Well, actually, looking at mine and seeing things like application/xml=mousepad.desktop
means I probably would have had I just not been thick as a brick. Oh well…

Seems, I’ve solved a problem. I run mv ~/.config/mimeapps.list ~/.config/mimeapps.list.back, and rebooted laptop. After reboot, I did this mv ~/.config/mimeapps.list.back ~/.config/mimeapps.list. This flow solve my problem

Does it still work after you reboot after moving the backup back?
Eg. 2nd reboot.

After 2nd, It returned. But seems, the problem was this row application/octet-stream=vlc.desktop; I’ve commented it, and now file association looks ok

of course
you restored the file to it’s original state - the situation now is exactly the same as it was before