Wrong colour text in the "help text" which appears then mouse is hovering over icon

After the latest update, some icons are not using the correct colour in the “help text” when I hover mouse pointer over them. It looks empty, but zooming in shows the text is there, its just the same colour as the background of the help text box.

When I open tray, click on bluetooth and then hover mouse over the"+" Icon, it appears to be an empty box. If i take a screenshot and zoom in on the “help text”, i can see the text faintly.


  Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=021ac587-2598-4e39-b7e0-5634da992ec8 rw apparmor=1 
  security=apparmor resume=UUID=3c820242-6b38-4805-ba9a-bda2db7c6952 
  Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Notebook 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8216 v: 83.18 serial: <filter> UEFI: Insyde v: F.52 
  date: 05/02/2019 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  Info: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP 
  arch: Amber Lake family: 6 model-id: 8E (142) stepping: 9 microcode: D6 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 23209 
  Speed: 638 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 
  4: 700 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Hewlett-Packard 
  driver: nvidia v: 455.38 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:134d 
  Device-3: Sunplus Innovation HP Wide Vision HD type: USB driver: uvcvideo 
  bus ID: 1-3:5 chip ID: 1bcf:2c87 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 
  driver: modesetting,nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4") 
  s-diag: 748mm (29.4") 
  Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
  OpenGL: renderer: GeForce 940MX/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.9.3-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard 
  driver: r8169 v: kernel port: 3000 bus ID: 03:00.0 chip ID: 10ec:8136 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: 3000 bus ID: 05:00.0 chip ID: 8086:24fb 
  IF: wlo1 state: down mac: <filter> 
  Local Storage: total: 2.26 TiB used: 715.25 GiB (31.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
  ID-2: /dev/sdb vendor: Western Digital model: WDS480G2G0A-00JH30 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 0400 scheme: GPT 
  ID-1: / raw size: 429.75 GiB size: 422.01 GiB (98.20%) 
  used: 94.15 GiB (22.3%) fs: ext4 dev: /dev/sdb2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 41 C 
  Fan Speeds (RPM): N/A 
  Processes: 212 Uptime: 24m Memory: 15.53 GiB used: 1.87 GiB (12.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1534 lib: 386 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08

Have you tried a different color scheme, a different application theme (with or without kvantum) or a different Plasma theme?

I don’t know what kvantum is.
As per your suggestion, I tried different plasma/application style and everything else works other than Oxygen in Plasma Style. I’ll report this problem to KDE forums. Now I have switched to a different theme.
Thanks for the suggestion!

1 Like

kvantum is a theme manager for applying SVG-based themes to KDE/Qt applications ─ the package is called kvantum-manager in the repository. There is a whole load of community-developed kvantum themes at store.kde.org.

Here’s the one I use, called Glow Mojave Dark ─ and here’s the light version.

And this is what it looks like on my machine here. :slight_smile:

Oxygen can normally be colorized using the chosen color scheme. kvantum themes cannot ─ or at least, not entirely ─ because they are SVG-based. However, with the kvantum-manager you can set a different theme for certain applications.

System SettingsAppearance → Colors

Also do note that GTK applications are a different beast altogether. They don’t follow the KDE/Qt themes and colors. You have to set those separately in System Settings.

Thank you for the information! I’ll look into it as soon as I can.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.