WPS Office theme conflicts with Manjaro Gnome Dark themes

WPS Office is showing problems in theming in Manjaro Gnome.

The problem is specifically with only dark themes.

Whenever the application theme is set to a dark theme in the Tweaks, the problem occurs.

The Formula bar is working seamlessly.

Now when the theme is set to Matcha Dark Sea the formula bar texts are not visible.

The same occurs with all dark themes.

And also the options in the menu of WPS shows the same problems.

Is there any solution??

I would prefer to use Matcha Dark themes.

WPS Office is a Qt-based application; while GNOME is a GTK-based desktop environment. GTK theming does not work well with Qt applications. You need to configure the latter separately with qt5ct or a similar tool, and if you set the Qt theme to kvantum ─ which is a theme engine ─ then you can load kvantum themes into the Kvantum Manager for further tweaks to the look & feel of Qt-based applications.


Manjaro gnome uses kvantum by default. Open kvantum and set the dark version of matchama theme, it is the kvantum equivalent of matcha.


The problem persists even after changing kvantum theme.

I am facing the same issue too. It persists with all QT applications I am currently using. I thought I messed up some configs of mine and tried reinstalling applications, theme engines and the themes themselves.

I guess its a bug from the recent update. Was fine earlier (yesterday before an upgrade). Hoping for a fix soon.

Here is a glitched out version of Kvantum itself while using the Matchama-Dark Theme xD
i (dot) imgur (dot) com/zN0Ky1Z.png

1 Like

I’ll test and look into this on Sunday.


Maybe @cscs can you look on this issue?

1 Like

Looks like it might be the same issue as some of the other ‘special cases’ that are on the opaque line of the .kvconfig file. But I havent been able to investigate just yet.


(same problem) I set option Matchama-dark and it worked! Thanks