World of Warcraft & launcher completely freeze after a random amount of time

After a seemingly random amount of time World of Warcraft will suddenly freeze and become completely unresponsive. The launcher also freezes at the same time, and even if WoW isn’t running this freeze can occur to the launcher alone.

It’s impossible to actively test solutions because sometimes it just doesn’t freeze at all for hours but freezes quickly the next day. I’ve tried multiple different wine versions but the issue still occurs, and the issue even followed me from a previous Arch installation. (All relevant applications were freshly installed on Manjaro)

Here’s a section from journalctl at the time of the freeze:

System Specs:

OS: Manjaro Linux
DISPLAY: X11, KDE Plasma
CPU: 12th Gen Intel Core i7-12700KF
GPU: NVIDIA GeForce RTX 3090
RAM: 30 GB

In addition to switching distros I also did a hardware upgrade recently. The issue was present before using the new hardware, and it has persisted through many driver updates.

Any help would be appreciated, I’m so exhausted having been dealing with this issue for so long.

I feel your pain. I am a blizzard junkie and it can be difficult to figure out why the freezes happen. It looks like wine is crashing. I have found that anything after wine 7.1 can be a problem, you might want to try versions in that range if you havent already. Also the Lutris forums may be another place to seek help and get solutions.
Lastly you may want to give more information on your hardware and drivers you are using.

Woops, definitely should have included specs before, thanks for the reminder! I’ve edited my post to include my system information.

Hey i have the identical issue with WoW via Lutris on my Manjaro. Have also tried different similar things with no success. Would appreciate any new idea or solution.

my specs:

OS: Manjaro Linux
DISPLAY: X11, KDE Plasma
CPU: Intel Core i9-9900KF
GPU: Radeon RX 6900 XT
GPU DRIVER: video-linux
RAM: 32 GB

Crashes are gone with lutris-ge-6.16-1-x86_64