[workaround] Rotate display at boot time

Hey there,

I use Plymouth at boot time, which is working fine.
However, I have two displays, both connected via DisplayPort.
One of these two is rotated by 90 degrees. The other one, not-rotated display, is my primary one and shows the bios/UEFI menu.

My goal is now to rotate the image of the roated display by 90 degrees so that Plymouth is displayed correctly. For this, I found that one can add a kernel parameter: “video=DP-0:panel_orientation=left_side_up” Adding this, however, doesn’t rotate the display. Interestingly, changing DP-0 to DP-2, so that the main display is rotated, it works just fine.

I suspect that at boot time, DP-2 isn’t recognized as connected as the display doesn’t register itself with no signal. This also seems to be true as when I disconnect my main display, the display is used to show the BIOD/UEFI and it works fine.

So, I tried to force the output by adding “video=DP-0:3840x2160@60:D” as kernel parameter. This made no difference though, it’s still not working.

Does someone here have an idea, how to solve this?

This is how my GRUB_CMDLINE_LINUX_DEFAULT line looks currently:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash udev.log_priority=3 video=DP-0:3840x2160@60:D video=DP-0:panel_orientation=left_side_up nvidia-drm.modeset=1”

Did I make a mistake here?

Thanks in advance!


That looks legit, whoever, in some instances DP-0 = DFP-2 and in other instances DP-0 = DFP-0

Thank you, I’l try that and report back!

I want to add though that I checked xrandr, which shows it as DP-0 FWIW

That’s a bit embrassing now, but I found another workaround: I just plugged them into different slots in my graphics card.

This doesn’t solve the original issue that DP-0 doesn’t work as input, while DP-2 does, but it works for me now.

Also, DFP-2 and DFP-0 didn’t work either. :frowning:

Thank you very much anyway! :slight_smile: